Objectifs de certification

ICND1 100-105

  • 3.7 Configurer, vérifier et dépanner RIPv2 pour IPv4 sauf authentification, filtrage, summarization manuelle, redistribution

CCNA R&S 200-125

  • 3.13 Configurer, vérifier et dépanner RIPv2 pour IPv4 sauf authentification, filtrage, summarization manuelle, redistribution

Lab routage RIPv2 VLSM

L’intérêt de la version 2 de RIP tient notamment au support des masques à longueur variable (VLSM) en IPv4. On propose une topologie d’étude à trois routeurs (tripod) qui suppose un bouclage dans les liaisons et pour laquelle on nous offre un bloc de 256 adresses pour satisfaire les besoins d’adressage.

1. Topologie

Topologie : routage RIPv2 VLSM

2. Plan d’adressage

AttributionContrainteRéseauPlage adressableDiffusion
LAN R1100 adresses192.168.1.0/25192.168.1.1/25 à 192.168.1.126/25192.168.1.127/25
LAN R250 adresses192.168.1.128/26192.168.1.129/26 à 192.168.1.190/26192.168.1.191/26
LAN R325 adresses192.168.1.192/27192.168.1.193/27 à 192.168.1.222/27192.168.1.223/27
R1-R24 adresses192.168.1.224/30192.168.1.225/30 à 192.168.1.226/30192.168.1.227/30
R1-R34 adresses192.168.1.228/30192.168.1.229/30 à 192.168.1.230/30192.168.1.231/30
R2-R34 adresses192.168.1.232/30192.168.1.233/30 à 192.168.1.234/30192.168.1.235/30

3. Configuration des routeurs

Configuration de R1 :

hostname R1
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.128
 no shutdown
!
interface GigabitEthernet0/2
 ip address 192.168.1.225 255.255.255.252
 no shutdown
!
interface GigabitEthernet0/3
 ip address 192.168.1.229 255.255.255.252
 no shutdown
!
ip dhcp pool LAN_R1
 network 192.168.1.0 255.255.255.128
 default-router 192.168.1.1
!
end
hostname R2
!
interface GigabitEthernet0/0
 ip address 192.168.1.129 255.255.255.192
 no shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.1.226 255.255.255.252
 no shutdown
!
interface GigabitEthernet0/3
 ip address 192.168.1.233 255.255.255.252
 no shutdown
!
ip dhcp pool LAN_R2
 network 192.168.1.128 255.255.255.192
 default-router 192.168.1.129
!
end
hostname R3
!
interface GigabitEthernet0/0
 ip address 192.168.1.193 255.255.255.224
 no shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.1.230 255.255.255.252
 no shutdown
!
interface GigabitEthernet0/2
 ip address 192.168.1.234 255.255.255.252
 no shutdown
!
ip dhcp pool LAN_R3
 network 192.168.1.192 255.255.255.224
 default-router 192.168.1.193
!
end

4. Activation du routage RIPv2

Respectivement sur chaque routeur :

router rip
 version 2
 network 192.168.1.0
 passive-interface G0/0

5. Vérification des liaisons

A partir de R1 vers R2 et R3 :

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.1     YES NVRAM  up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/2         192.168.1.225   YES NVRAM  up                    up
GigabitEthernet0/3         192.168.1.229   YES NVRAM  up                    up

R1#ping 192.168.1.226
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.226, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/6 ms
R1#ping 192.168.1.230
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.230, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/5 ms

A partir de R2 vers R3 :

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.129   YES NVRAM  up                    up
GigabitEthernet0/1         192.168.1.226   YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         192.168.1.233   YES NVRAM  up                    up

R2#ping 192.168.1.234
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.234, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/7 ms

6. Vérification de la configuration du routage

Sur R1 :

R1#show ip protocols | begin rip
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 13 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    GigabitEthernet0/2    2     2
    GigabitEthernet0/3    2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.226        120      00:00:27
    192.168.1.230        120      00:00:12
  Distance: (default is 120)

Sur R2 :

R2#show ip protocols | begin rip
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 22 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    GigabitEthernet0/1    2     2
    GigabitEthernet0/3    2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.234        120      00:00:28
    192.168.1.225        120      00:00:26
  Distance: (default is 120)

Sur R3 :

R3#show ip protocols | begin rip
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 18 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    GigabitEthernet0/1    2     2
    GigabitEthernet0/2    2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.233        120      00:00:17
    192.168.1.229        120      00:00:05
  Distance: (default is 120)

7. Vérification des tables de routage

Sur R1 :

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

      192.168.1.0/24 is variably subnetted, 9 subnets, 5 masks
R        192.168.1.128/26
           [120/1] via 192.168.1.226, 00:00:16, GigabitEthernet0/2
R        192.168.1.192/27
           [120/1] via 192.168.1.230, 00:00:28, GigabitEthernet0/3
R        192.168.1.232/30
           [120/1] via 192.168.1.230, 00:00:28, GigabitEthernet0/3
           [120/1] via 192.168.1.226, 00:00:16, GigabitEthernet0/2

Sur R2 :

R2#show ip route rip | begin Gateway
Gateway of last resort is not set

      192.168.1.0/24 is variably subnetted, 9 subnets, 5 masks
R        192.168.1.0/25
           [120/1] via 192.168.1.225, 00:00:18, GigabitEthernet0/1
R        192.168.1.192/27
           [120/1] via 192.168.1.234, 00:00:17, GigabitEthernet0/3
R        192.168.1.228/30
           [120/1] via 192.168.1.234, 00:00:17, GigabitEthernet0/3
           [120/1] via 192.168.1.225, 00:00:18, GigabitEthernet0/1

Sur R3 :

R3#show ip route rip | begin Gateway
Gateway of last resort is not set

      192.168.1.0/24 is variably subnetted, 9 subnets, 5 masks
R        192.168.1.0/25
           [120/1] via 192.168.1.229, 00:00:14, GigabitEthernet0/1
R        192.168.1.128/26
           [120/1] via 192.168.1.233, 00:00:15, GigabitEthernet0/2
R        192.168.1.224/30
           [120/1] via 192.168.1.233, 00:00:15, GigabitEthernet0/2
           [120/1] via 192.168.1.229, 00:00:14, GigabitEthernet0/1

8. Vérification de la connectivité de bout en bout

De PC2 à PC3 :

[root@pc3 ~]# ip a s dev ens3
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:ad:d5:c9:79:00 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.194/27 brd 192.168.1.223 scope global dynamic ens3
       valid_lft 80137sec preferred_lft 80137sec
    inet6 fe80::2ad:d5ff:fec9:7900/64 scope link
       valid_lft forever preferred_lft forever
[root@pc3 ~]# ping -c 1 192.168.1.130
PING 192.168.1.130 (192.168.1.130) 56(84) bytes of data.
64 bytes from 192.168.1.130: icmp_seq=1 ttl=62 time=16.1 ms

--- 192.168.1.130 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 16.176/16.176/16.176/0.000 ms

9. Activation de l’Internet

interface g0/1
ip address dhcp
no shutdown
access-list 1 permit 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface g0/1 overload
interface g0/0
ip nat inside
interface g0/2
ip nat inside
interface g0/3
ip nat inside
interface g0/1
ip nat outside
end
wr

Laisser un commentaire