Objectifs de certification

CCNA R&S 200-125

  • 3.13 Configurer, vérifier et dépanner RIPv2 pour IPv4 sauf authentification, filtrage, summarization manuelle, redistribution


Lab routage RIPv2 simple

Cet exercice reprend la topologie de deux routeurs interconnectés entre eux (R1 et R2) connectent chacun un LAN adressé en IPv4 et en IPv6. L’exercice consiste à implémenter le routage dynamique RIPv2, à le configurer et à le dépanner. On invitera le lecteur à jouer avec la distance administrative des routes statiques et à réfléchir aux configurations assez simples qui sont proposées.

1. Topologie

Topologie : routage RIPv2 simple

2. Configuration des interfaces sur R1

hostname R1
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet0/2
 ip address 192.168.3.1 255.255.255.0
 no shutdown
!
ip dhcp pool LAN
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
!
end

3. Configuration des interfaces sur R2

hostname R2
!
interface GigabitEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.3.2 255.255.255.0
 no shutdown
!
ip dhcp pool LAN
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.1
!
end

4. Vérification des interfaces

Sur R1 :

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.1.1     YES NVRAM  up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/2         192.168.3.1     YES NVRAM  up                    up
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down

Sur R2 :

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.2.1     YES NVRAM  up                    up
GigabitEthernet0/1         192.168.3.2     YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down

Test de connectivité sur le voisinage :

R1#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/7 ms

5. Activation du routage RIPv2

Respectivement, sur chaque routeur :

  • activation la version 2

  • l’interface LAN est passive

  • déclaration des réseaux directement connectés

Sur R1 :

router rip
 version 2
 passive-interface GigabitEthernet0/0
 network 192.168.1.0
 network 192.168.3.0

Sur R2 :

router rip
 version 2
 passive-interface GigabitEthernet0/0
 network 192.168.2.0
 network 192.168.3.0

6. Vérification de la configuration RIPv2

Sur R1 :

R1#show ip protocols | begin rip
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 27 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    GigabitEthernet0/2    2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
    192.168.3.0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.3.2          120      00:00:27
  Distance: (default is 120)

Sur R2 :

R2#show ip protocols | begin rip
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 18 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    GigabitEthernet0/1    2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.2.0
    192.168.3.0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.3.1          120      00:00:01
  Distance: (default is 120)

7. Vérification de la table de routage

Sur R1 :

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.1/32 is directly connected, GigabitEthernet0/0
R     192.168.2.0/24 [120/1] via 192.168.3.2, 00:00:18, GigabitEthernet0/2
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, GigabitEthernet0/2
L        192.168.3.1/32 is directly connected, GigabitEthernet0/2

Sur R2 :

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:16, GigabitEthernet0/1
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.1/32 is directly connected, GigabitEthernet0/0
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, GigabitEthernet0/1
L        192.168.3.2/32 is directly connected, GigabitEthernet0/1

8. Vérification de la base de donnée RIP

Sur R2 :

R2#show ip rip database
192.168.1.0/24    auto-summary
192.168.1.0/24
    [1] via 192.168.3.1, 00:00:04, GigabitEthernet0/1
192.168.2.0/24    auto-summary
192.168.2.0/24    directly connected, GigabitEthernet0/0
192.168.3.0/24    auto-summary
192.168.3.0/24    directly connected, GigabitEthernet0/1

9. Debug RIP

En production, on redigera les logs ailleurs que dans la console.

R2#debug ip rip ?
  bfd       RIP BFD Events
  database  RIP database events
  events    RIP protocol events
  trigger   RIP trigger extension
  <cr>

R2#debug ip rip
RIP protocol debugging is on

*Oct 22 13:48:15.686: RIP: received v2 update from 192.168.3.1 on GigabitEthernet0/1
*Oct 22 13:48:15.686:      192.168.1.0/24 via 0.0.0.0 in 1 hops
*Oct 22 13:48:39.979: RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/1 (192.168.3.2)
*Oct 22 13:48:39.980: RIP: build update entries
*Oct 22 13:48:39.980: 	192.168.2.0/24 via 0.0.0.0, metric 1, tag 0
*Oct 22 13:48:44.050: RIP: received v2 update from 192.168.3.1 on GigabitEthernet0/1
*Oct 22 13:48:44.051:      192.168.1.0/24 via 0.0.0.0 in 1 hops
*Oct 22 13:48:39.979: RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/1 (192.168.3.2)
*Oct 22 13:48:39.980: RIP: build update entries
*Oct 22 13:48:39.980: 	192.168.2.0/24 via 0.0.0.0, metric 1, tag 0
*Oct 22 13:48:44.050: RIP: received v2 update from 192.168.3.1 on GigabitEthernet0/1
*Oct 22 13:48:44.051:      192.168.1.0/24 via 0.0.0.0 in 1 hops
*Oct 22 13:49:06.592: RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/1 (192.168.3.2)
*Oct 22 13:49:06.593: RIP: build update entries
*Oct 22 13:49:06.593: 	192.168.2.0/24 via 0.0.0.0, metric 1, tag 0
*Oct 22 13:49:09.792: RIP: received v2 update from 192.168.3.1 on GigabitEthernet0/1
*Oct 22 13:49:09.792:      192.168.1.0/24 via 0.0.0.0 in 1 hops

On peut arrêter tout debug :

R2#undebug all
All possible debugging has been turned off

10. Routes flottantes

À compléter.

Laisser un commentaire