En Une :

Prise en main et configuration d'un routeur Cisco

Cet exercice avec un routeur Cisco consiste à s'initier à la ligne de commande IOS sur un routeur avec un exercice de configuration initiale qui vise à :

  • Se connecter au terminal physique d'un périphérique Cisco
  • Apprendre à utiliser, à s'informer, à naviguer dans l'IOS Cisco avec son CLI
  • A placer une configuration initiale sécurisée avec un accès distant SSH à titre de bonne pratique.
  • Configurer des interfaces en IPv4 et en IPv6
  • Activer le routage IPv4 / IPv6
  • Enregistrer la configuration courante et à la vérifier

La plupart des commandes de configuration globale et des interfaces envisagées ici sont également valides sur les commutateurs dans la mesure de leurs spécificités.

1. Connexion à un périphérique Cisco

1.1. Connexion série / console

  • Câble inversé (roll-over) du port COM1 du PC au routeur sur le port console.
  • Lancer un logiciel d'émulation de terminal (putty/hyperterminal) 9600 bauds, 8, n, 1.

1.2. Password Recovery

À vrai dire, la procédure "password recovery", "recouvrement de mot de passe", ne permet pas de retrouver un mot de passe d'un routeur Cisco.

Tout au plus, elle permet de reprendre la main sur un routeur dont l'accès est limité par un mot de passe, de le changer ou de le lire si celui-ci n’est pas chiffré.
En laboratoire, cette procédure nous permettra de travailler sur des machines dont la configuration est vierge.

La procédure est bien distincte pour un commutateur Cisco car il s'agit d'une plateforme différente sur le plan matériel.

Ce sujet est développé dans ICND2.

2. Méthode Cisco CLI

2.1. Introduction

Un grand nombre de produits Cisco (routeurs, commutateurs, point d'accès, pare-feux, etc.) sont hautement configurables en ligne de commande (CLI) IOS.

Une commande validée est immédiatement exécutée en mémoire vive. Les commandes répondent à une certaine logique qui généralement suit celle des protocoles mis en oeuvre.

Les tâches de diagnostic sont simples et explicites.

Une aide performante accompagne ce mode de configuration.

Certaines configurations peuvent comporter un grand nombre de lignes mais sont susceptibles de subir des automations (exécution de scripts, traitement du texte, copier/coller en console, téléchargement de configuration en FTP ou TFTP, etc.). L'IOS évolue avec les besoins des clients qui demandent de configurations robustes et lisibles. Par exemple, les valeurs par défaut n'apparaissent pas explicitement dans la configuration. La lecture est simplifiée mais la connaissance des protocoles et du produit devient cruciale. Il s'agit d'un très bon exercice des professionnels du domaine car ce type d'environnement est souvent rencontré.

Il existe d'autres modes de configuration que la ligne de commande tels que par un navigateur Web ou un logiciel JAVA exécuté en local ou à distance tel que SDM. Mais ces modes nécessitent la plupart du temps une configuration TCP/IP préalable qu'il faudra exécuter en ligne de commande. Ces modes de configuration établissent un tunnel TCP/IP sécurisé pour exécuter les commandes à distance à travers un logiciel client et transférer des fichiers.

Ces méthodes de configuration et de gestion en ligne de commande sont identiques sur un routeur ou un commutateur faisant fonctionner l'IOS Cisco. On peut considérer que l'on est proche d'un environnement de type "shell" proche d'autres systèmes d'exploitation bien connus. On peut aussi considérer que le CLI Cisco IOS est une compétence encore très recherchée aujourd'hui.

2.2. Hiérachie CLI

On se base sur l’invite pour se situer dans un mode. Il faut les droits d’administration (mode privilège) pour exécuter des tâches de diagnostic ou de gestion. Toutes les commandes de configuration de la machine s’exécutent en mode de configuration globale. Toutes les commandes spécifiques pour les interfaces, le routage, des services (dhcp, nat, firewall, ...) ont leur mode configuration particulier.

On trouve au moins trois niveaux hiérarchiques CLI principaux :

  1. Mode utilisateur (User EXEC mode) : session, diagnostic
  • Mode privilège (Priviliged EXEC mode) : Administration et gestion (commandes show, debug, copy, erase, ...)
    • Mode configuration globale (Global Configuration mode)
    • Modes de configuration spécifiques

2.3. Passage en mode privilège

Router>enable
Router#

C'est le mode "root" du router. Dans ce mode aucune commande de configuration n'est admise.

Il supporte uniqument des commandes :

  • d'information : debug, show, telnet, ssh, ...
  • de diagnostic : ping, ...
  • de gestion : telnet, ssh, erase, copy, ...

2.4. Passage en mode de configuration globale

Pour configurer le routeur, il est nécessaire de passer en configuration globale. Ce mode ne supporte aucunes des commandes du mode privilège.

Router#configure terminal
Router(config)#

2.5. Configuration d’une interface

Router(config)#interface GigabitEthernet 0/0
Router(config-if)#

2.6. Passage aux modes inférieurs

Router(config-if)#exit
Router(config)#exit
Router#

2.7. Aide, auto-complétion, historique, raccourcis, confort

1. Aide

Une aide est accessible via le point d’interrogation ?.

Router#show ?
  aaa                       Show AAA values
  access-expression         List access expression
  access-lists              List access lists
  acircuit                  Access circuit info
  adjacency                 Adjacent nodes
  aliases                   Display alias commands
  alps                      Alps information
  appfw                     Application Firewall information
  application               Application Routing
  archive                   Archive functions
  arp                       ARP table
  async                     Information on terminal lines used as router
                            interfaces
  authentication            Shows Auth Manager registrations or sessions
  auto                      Show Automation Template
  backhaul-session-manager  Backhaul Session Manager information
  backup                    Backup status
  banner                    Display banner information
  beep                      Show BEEP information
  bfd                       BFD protocol info
  bgp                       BGP information
  bootvar                   Boot and related environment variable
--More--

Router#show ip ?
  access-lists            List IP access lists
  accounting              The active IP accounting database
  admission               Network Admission Control information
  aliases                 IP alias table
  arp                     IP ARP table
  as-path-access-list     List AS path access lists
  auth-proxy              Authentication Proxy information
  bgp                     BGP information
  cache                   IP fast-switching route cache
  cef                     Cisco Express Forwarding
  community-list          List community-list
  ddns                    Dynamic DNS
  device                  Show IP Tracking Hosts
  dfp                     DFP information
  dhcp                    Show items in the DHCP database
  dns                     Show DNS information
  dns-cache               Show addresses in DNS cache
  dns-snoop-cache         Show addresses in DNS snoop cache
  drp                     Director response protocol
  eigrp                   Show IPv4 EIGRP
  explicit-paths          Show IP explicit paths
  extcommunity-list       List extended-community list
 --More--

Router#show ip interface ?
  Async              Async interface
  Auto-Template      Auto-Template interface
  BDI                Bridge-Domain interface
  BVI                Bridge-Group Virtual Interface
  CDMA-Ix            CDMA Ix interface
  CTunnel            CTunnel interface
  Dialer             Dialer interface
  GMPLS              MPLS interface
  GigabitEthernet    GigabitEthernet IEEE 802.3z
  LISP               Locator/ID Separation Protocol Virtual Interface
  LongReachEthernet  Long-Reach Ethernet interface
  Loopback           Loopback interface
  Lspvif             LSP virtual interface
  MFR                Multilink Frame Relay bundle interface
  Multilink          Multilink-group interface
  Null               Null interface
  Tunnel             Tunnel interface
  Vif                PGM Multicast Host interface
  Virtual-PPP        Virtual PPP interface
  Virtual-Template   Virtual Template interface
  Virtual-TokenRing  Virtual TokenRing
  brief              Brief summary of IP status and configuration
 --More--

2. Autocomplétion

  • Les commandes s’auto-complètent avec la touche de tabulation.

#sh <tabulation> devient #show

3. Signalement d'erreurs

L’environnement indique l’endroit d’une erreur.

Router#shown con
           ^
% Invalid input detected at '^' marker.


4. Commandes abrégées

Les commandes s’abrègent s’il n’y a pas d’ambiguïté.

Router#conf t

au lieu de #configure terminal

Router#sh ip int b

au lieu de show ip interface brief

Router#copy r s

au lieu de copy run start ou copy running-config startup-config

Sans confirmation :

Router#wr

au lieu de write memory

Dernier exemple sur les interfaces

Router(config)#int g0/0

au lieu de (config)#interface GigabitEthernet 0/0

5. Ambiguïté

  • En cas d’ambiguïté, l’environnement propose les choix.
Router#con t
% Ambiguous command:  "con t"
Router#con
Router#con
Router#con?
configure  connect  

Router#con

6. Raccourcis clavier

Raccourcis clavier : on peut faire défiler l’historique des commandes avec les flèches du haut et du bas, on peut revenir au mode privilège directement (CTRL-Z), etc.

Séquence Description
CTRL-A Début de ligne
CTRL-E Fin de ligne
CTRL-P ou bas Commande précédente
CTRL-N ou haut Commande suivante
CTRL-F ou droite Curseur vers la droite
CTRL-B ou gauche Curseur vers la gauche
CTRL-Z Retour au mode privilège
CRTL-C Interruption
CTRL-SHIFT-6 / CTRL-SHIFT§ Interruption forcée
TAB Complète un commande
Backspace Efface un caractère vers la gauche
CTRL-R Réaffichage de la ligne
CTRL-U Efface la ligne
CTRL-W Efface un mot
ESC-B Ecarte un mot
ESC-F Avance un mot

7. Commande do

La commande do permet d’exécuter une commande du mode privilège dans un autre mode.

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#show run
                 ^
% Invalid input detected at '^' marker.

Router(config)#do show run
Building configuration...


8. Apparition des logs

Par défaut les logs apparaissent dans la console, mais pas en terminal distant.

Dans une session Telnet ou SSH, les logs apparaissent suite à la commande :

Router#terminal monitor

9. Messages synchronisés de la console

On peut recevoir des messages du routeur qui trouble l'entrée des commandes. Voici une illustration :

Router#confi
%SYS-5-CONFIG_I : Configured from console by consolegure
Enter configuration commands, one per line. End with CNTL/Z.
Router#

Pour éviter ce problème, on peut demander un logging synchronous sur la console :

Router(config)#line con 0
Router(config-line)#logging synchronous

Voici l'éventuel résultat :

Router#confi
%SYS-5-CONFIG_I : Configured from console by console
Router#configure

10. Désactivation des recherches DNS

Sans résolution DNS, une frappe erronée ne correspondant pas à une commande peut être interprétée en mode privilège comme une tentative de connexion distante SSH et bloquer un certain temps la console :

Router#zozo

On désactive la recherche DNS avec la commande :

Router(config)# no ip domain-lookup

ou

Router(config)# no ip domain lookup

3. Scénario d'exercice

Le scénario de base est le suivant. Un routeur connecte deux LANs.

  • un réseau local (LAN1) adressé sur l'interface G0/0 :
  • en IPv4 en 192.168.1.254/24
  • en IPv6 en FD00:192:168:1::254/64
  • en IPv6 en FE80::1/64
  • un réseau local (LAN2) adressé sur l'interface G0/1 :
  • en IPv4 en 192.168.2.254/24
  • en IPv6 en FD00:192:168:2::fe/64
  • en IPv6 en FE80::1/64

On trouvera un PC1 dans LAN1 adressé en IPv4 en 192.168.1.1/24 et en autoconfiguration IPv6.

On trouvera un PC2 dans LAN2 adressé en IPv4 en 192.168.2.2/24 et en autoconfiguration IPv6.

3.1. Vérification de l'état des interfaces

Toutes les interfaces sont désactivées administrativement colonne "Status".

Router#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         unassigned      YES unset  administratively down down    
GigabitEthernet0/1         unassigned      YES unset  administratively down down    
GigabitEthernet0/2         unassigned      YES unset  administratively down down    
GigabitEthernet0/3         unassigned      YES unset  administratively down down    

3.2. Vérification de la configuration par défaut

Observer :

  • Le nom
  • Les paramètres d'interfaces IPv4 / IPv6
  • La partie control plane
Router#show running-config
Building configuration...

Current configuration : xxx bytes
!
! Last configuration change at 20:29:30 UTC Tue Apr 25 2017
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
no aaa new-model
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
no cdp log mismatch duplex
!
ip tcp synwait-time 5
!
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
no ip http server
no ip http secure-server
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
**************************************************************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
end

4. Configuration initiale du routeur

Accès à la console du routeur, éventuellement après la procédure password recovery.

4.1. Configuration globale

Toutes les commandes de configuration s’exécutent ici en mode de configuration globale (config)#.

1. Configuration du nom du périphérique

Router(config)#hostname R1

2. Configuration du mot de passe privilège

R1(config)#enable secret testtest

Vérification du mot de passe dans la configuration courante.

R1(config)#do sh run | include enable secret
enable secret 5 $1$VRPj$Zedd82KU72UbV8qaJ4/Ut0

Par défaut le mot de passe "enable" est chiffré en MD5.

Quels sont les autres algorithmes de chiffrement disponibles dans cette version d'IOS ?

R1(config)#enable algorithm-type ?
  md5     Encode the password using the MD5 algorithm
  scrypt  Encode the password using the SCRYPT hashing algorithm
  sha256  Encode the password using the PBKDF2 hashing algorithm

Finalement, on peut chiffrer le mot de passe en SHA256.

R1(config)#enable algorithm-type sha256 secret testtest
R1(config)#do sh run | include enable secret           
enable secret 8 $8$VFFgMwf75tN03c$1dkzDKckXIkMYjRDx.r3u4DFYqLX6L0R7IajwPaOkTw

3. Chiffrement automatique de tous les mots de passe

Applique automatiquement l'algorithme de Vigenere à des fins de discrétion pour cacher des mots de passes en clair dans une configuration. Il s'agit d'une première mesure de protection quand les algorithmes de chiffrement étaient moins disponibles sur les plateformes Cisco (plus de 10 ans).

R1(config)#service password-encryption

4. Créer un compte d’administration

R1(config)#username root secret testtest
R1(config)#do sh run | include user
username root secret 5 $1$cHUp$RUQIE4IFCfLtVldLXFemI1

R1(config)#username root algorithm-type sha256 secret testtest
R1(config)#do sh run | include user                           
username root secret 8 $8$HdW.W3ndcTWqRM$tPiGLKwz/YnOlSXlru3dJtpR31f.T0Uei702NyWumlw

4.2. Configurer et sécuriser SSH

1. Donner un nom de domaine au périphérique

R1(config)#ip domain-name mon.lan

2. Générer une clé RSA d’une certaine longueur

R1(config)#crypto key generate rsa
The name for the keys will be: Gateway.mon.lan
Choose the size of the key modulus in the range of 360 to 4096 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.
  How many bits in the modulus [512]: 2048
  % Generating 2048 bit RSA keys, keys will be non-exportable...
  [OK] (elapsed time was 3 seconds)

(config)#
  *Apr 25 21:36:46.315: %SSH-5-ENABLED: SSH 1.99 has been enabled

3. Configuration de la console distante

Activer le protocole SSH version 2 dans les lignes virtuelles (VTY) et indiquer la base de donnée locale pour l’authentification

R1(config)#ip ssh version 2
R1(config)#line vty 0 4
R1(config-line)#transport input ssh
R1(config-line)#login local

4. Configuration d'une bannière d'accueil (MOTD Banner)

On peut configurer une bannière d'accueil dès que l'on accède au routeur. On l'appelle la Message Of The Day (MOTD) Banner. Voici la procédure.

R1(config)#banner motd #
Enter TEXT message End with the character '#'.
Toute entrée non autorisée est interdite.
#
R1(config)#
Le message doit se terminer par le dièse.

5. Configuration initiale des interfaces et du routage IPv4/IPv6

En configuration globale (config)#.

5.1. Configurer l’interface LAN1

Configuration de l’interface en IPv4/IPv6. Montage de l’interface.

R1(config)#interface GigabitEthernet0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.1.254 255.255.255.0
R1(config-if)#ipv6 address fe80::1 link-local
R1(config-if)#ipv6 address fd00:192:168:1::254/64
R1(config-if)#exit

5.2. Configurer l’interface LAN2

Configuration de l’interface en IPv4/IPv6. Montage de l’interface.

R1(config)#interface GigabitEthernet0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.2.254 255.255.255.0
R1(config-if)#ipv6 address fe80::1 link-local
R1(config-if)#ipv6 address fd00:192:168:2::fe/64
R1(config-if)#exit

5.3. Activer et configurer le routage

Le routage IPv4 (ip routing) est activé contrairement au routage IPv6.

R1(config)#ipv6 unicast-routing

5.4. Commandes de configuration accessoires

...

6. Tâches administratives

6.1 Enregistrement de la configuration

R1#copy running-config startup-config

6.2. Vérification de la configuration en mémoire vive

R1#show running-config

6.3. Vérification de l'état des interfaces

show interface g0/0 → diagnostic avancé sur les erreurs couche 2

6.4. Vérification des paramètres IPv4

  • show ip interface brief → diagnostic bref interface/line protocol
  • show ip interface g0/0 → diagnostic sur ICMP/ARP

6.5. Vérification des paramètres IPv6

  • show ipv6 interface brief → diagnostic bref interface/line protocol
  • show ipv6 interface g0/0 → diagnostic sur ICMP/ARP

6.6. Examen des tables de routage IPv4 et IPv6

  • show [ip | ipv6] route → visualise la table de routage

7. Configuration des hôtes terminaux

Veuillez lancer les PC sur chaque LAN et configurer leur interface en IPv4 et en IPv6.

Par exemple, sous Linux Ubuntu :

Pour PC1 :

sudo su
int="eth0"
net4="192.168.1"
net6="fd00:192:168:1"
hostnamectl set-hostname PC1
systemctl stop networking
ip add add ${net4}.1/24 dev ${int}
ip -6 add add ${net6}::c1/64 dev ${int}
ip link set dev ${int} up
ip route add default via ${net4}.254
ip add

Pour PC2 :

int="eth0"
net4="192.168.2"
net6="fd00:192:168:2"
hostnamectl set-hostname PC2
systemctl stop networking
ip add add ${net4}.1/24 dev ${int}
ip -6 add add ${net6}::c2/64 dev ${int}
ip link set dev ${int} up
ip route add default via ${net4}.254
ip add

Sous Centos 7, on utilisera volontiers nmtui :

# nmtui


                           ┌─┤ NetworkManager TUI ├──┐
                           │                         │
                           │ Please select an option │
                           │                         │
                           │ Edit a connection       │
                           │ Activate a connection   │
                           │ Set system hostname     │
                           │                         │
                           │ Quit                    │
                           │                         │
                           │                    <OK> │
                           │                         │
                           └─────────────────────────┘


Choisir et valider "Edit a connection".


                          ┌───────────────────────────┐
                          │                           │
                          │ ┌─────────────┐           │
                          │ │ Ethernet  ↑ │ <Add>     │
                          │ │   eth0    ▒ │           │
                          │ │           ▒ │ <Edit...> │
                          │ │           ▒ │           │
                          │ │           ▒ │ <Delete>  │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▮ │           │
                          │ │           ↓ │ <Back>    │
                          │ └─────────────┘           │
                          │                           │
                          └───────────────────────────┘


Positionner le curseur sur "<Edit...>" et valider.


   ┌───────────────────────────┤ Edit Connection ├───────────────────────────┐
   │                                                                         │
   │         Profile name eth0____________________________________           │
   │               Device eth0 (00:57:8A:96:83:00)________________           │
   │                                                                         │
   │ ═ ETHERNET          ┌────────────┐                            <Show>    │
   │                     │ Disabled   │                                      │
   │ ═ IPv4 CONFIGURATION│ Automatic  │                            <Show>    │
   │ ═ IPv6 CONFIGURATION│ Link-Local │                            <Show>    │
   │                     │ Manual     │                                      │
   │ [X] Automatically co│ Shared     │                                      │
   │ [X] Available to all└────────────┘                                      │
   │                                                                         │
   │                                                           <Cancel> <OK> │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   └─────────────────────────────────────────────────────────────────────────┘


Aller sur "IPv4 CONFIGURATION│ Automatic" et choisir "Manual".


   ┌───────────────────────────┤ Edit Connection ├───────────────────────────┐
   │                                                                        ↑│
   │         Profile name eth0____________________________________          ▮│
   │               Device eth0 (00:57:8A:96:83:00)________________          ▒│
   │                                                                        ▒│
   │ ═ ETHERNET                                                    <Show>   ▒│
   │                                                                        ▒│
   │ ╤ IPv4 CONFIGURATION <Manual>                                 <Hide>   ▒│
   │ │          Addresses <Add...>                                          ▒│
   │ │            Gateway _________________________                         ▒│
   │ │        DNS servers <Add...>                                          ▒│
   │ │     Search domains <Add...>                                          ▒│
   │ │                                                                      ▒│
   │ │            Routing (No custom routes) <Edit...>                      ▒│
   │ │ [ ] Never use this network for default route                         ▒│
   │ │ [ ] Ignore automatically obtained routes                             ▒│
   │ │                                                                      ▒│
   │ │ [ ] Require IPv4 addressing for this connection                      ▒│
   │ └                                                                      ▒│
   │                                                                        ▒│
   │                                                                        ↓│
   └─────────────────────────────────────────────────────────────────────────┘


Sur la ligne "IPv4 CONFIGURATION ", valider show pour découvrir le menu IPv4.

Aller sur la ligne "Addresses <Add...>" et remplir l'adresse de PC1 par exemple 192.168.1.1/24 et sur "Gateway" et en indiquant l'adresse de la passerelle 192.168.1.254.


   ┌───────────────────────────┤ Edit Connection ├───────────────────────────┐
   │                                                                        ↑│
   │         Profile name eth0____________________________________          ▮│
   │               Device eth0 (00:57:8A:96:83:00)________________          ▒│
   │                                                                        ▒│
   │ ═ ETHERNET                                                    <Show>   ▒│
   │                                                                        ▒│
   │ ╤ IPv4 CONFIGURATION <Manual>                                 <Hide>   ▒│
   │ │          Addresses 192.168.1.1/24___________ <Remove>                ▒│
   │ │                    <Add...>                                          ▒│
   │ │            Gateway 192.168.1.254____________                         ▒│
   │ │        DNS servers <Add...>                                          ▒│
   │ │     Search domains <Add...>                                          ▒│
   │ │                                                                      ▒│
   │ │            Routing (No custom routes) <Edit...>                      ▒│
   │ │ [ ] Never use this network for default route                         ▒│
   │ │ [ ] Ignore automatically obtained routes                             ▒│
   │ │                                                                      ▒│
   │ │ [ ] Require IPv4 addressing for this connection                      ▒│
   │ └                                                                      ▒│
   │                                                                        ↓│
   └─────────────────────────────────────────────────────────────────────────┘


Aller au fond de la page et valider sur show de la ligne "".


   ┌───────────────────────────┤ Edit Connection ├───────────────────────────┐
   │                                                                        ↑│
   │ │                    <Add...>                                          ▒│
   │ │            Gateway 192.168.1.254____________                         ▒│
   │ │        DNS servers <Add...>                                          ▒│
   │ │     Search domains <Add...>                                          ▒│
   │ │                                                                      ▒│
   │ │            Routing (No custom routes) <Edit...>                      ▒│
   │ │ [ ] Never use this network for default route                         ▒│
   │ │ [ ] Ignore automatically obtained routes                             ▒│
   │ │                                                                      ▒│
   │ │ [ ] Require IPv4 addressing for this connection                      ▒│
   │ └                                                                      ▒│
   │                                                                        ▒│
   │ ═ IPv6 CONFIGURATION <Automatic>                              <Show>   ▒│
   │                                                                        ▒│
   │ [X] Automatically connect                                              ▒│
   │ [X] Available to all users                                             ▒│
   │                                                                        ▒│
   │                                                           <Cancel> <OK>▮│
   │                                                                        ↓│
   └─────────────────────────────────────────────────────────────────────────┘


Le menu de configuration IPv6 de l'interface se découvre.


   ┌───────────────────────────┤ Edit Connection ├───────────────────────────┐
   │                                                                        ↑│
   │                                                                        ▒│
   │ ╤ IPv6 CONFIGURATION <Manual>                                 <Hide>   ▒│
   │ │          Addresses FD00:192:168:1::c1/64____ <Remove>                ▒│
   │ │                    <Add...>                                          ▒│
   │ │            Gateway _________________________                         ▒│
   │ │        DNS servers <Add...>                                          ▒│
   │ │     Search domains <Add...>                                          ▒│
   │ │            Routing (No custom routes) <Edit...>                      ▒│
   │ │ [ ] Never use this network for default route                         ▒│
   │ │ [ ] Ignore automatically obtained routes                             ▒│
   │ │                                                                      ▒│
   │ │ [ ] Require IPv6 addressing for this connection                      ▒│
   │ └                                                                      ▒│
   │                                                                        ▒│
   │ [X] Automatically connect                                              ▒│
   │ [X] Available to all users                                             ▒│
   │                                                                        ▒│
   │                                                           <Cancel> <OK>▮│
   │                                                                        ↓│
   └─────────────────────────────────────────────────────────────────────────┘

Configurer en mode "" et fixer l'adresse IPv6 de l'interface en FD00:192:168:1::c1/64 et puis valider en bas de la page sur ""


                          ┌───────────────────────────┐
                          │                           │
                          │ ┌─────────────┐           │
                          │ │ Ethernet  ↑ │ <Add>     │
                          │ │   eth0    ▒ │           │
                          │ │           ▒ │ <Edit...> │
                          │ │           ▒ │           │
                          │ │           ▒ │ <Delete>  │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▒ │           │
                          │ │           ▮ │           │
                          │ │           ↓ │ <Back>    │
                          │ └─────────────┘           │
                          │                           │
                          └───────────────────────────┘


Aller sur "" et aller sur "Activate a connection".


 ┌─┤ NetworkManager TUI ├──┐
 │                         │
 │ Please select an option │
 │                         │
 │ Edit a connection       │
 │ Activate a connection   │
 │ Set system hostname     │
 │                         │
 │ Quit                    │
 │                         │
 │                    <OK> │
 │                         │
 └─────────────────────────┘

A cet endroit on désactive/ré-active l'interface :


                          ┌────────────────────────────┐
                          │                            │
                          │ ┌───────────┐              │
                          │ │ Wired   ↑ │ <Deactivate> │
                          │ │ * eth0  ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▒ │              │
                          │ │         ▮ │              │
                          │ │         ↓ │ <Back>       │
                          │ └───────────┘              │
                          │                            │
                          └────────────────────────────┘


Sortir de nmtui en allant sur "" et puis "Quit"

8. Diagnostic

8.1. A partir de R1 en IPv4/IPv6

ping [ipv6] → test de connectivité

  • sur les adresses des PCs en IPv4
  • sur les adresses link-local des PCs

8.2. A partir des PCs en IPv4/IPv6

ip add
ip route
ip -6 route
ping
traceroute
traceroute6
ssh [email protected]
  • sur la passerelle, sur la station distante en IPv4
  • sur l'adresse link-local (fe80::1) de la passerelle, sur la station distante en IPv6

8.3. Questions

Veuillez répondre à ces questions (en justifiant de la commande utilisée).

  1. Que signifient les termes "Status" et “Protocol” à propos d’une interface Cisco ?
  • Quel est le MTU de l’interface G0/0 de R1 ?
  • Quelles sont les statistiques concernant les erreurs de protocole de couche liaison de données (couche 2) ?
  • Quelle est l’encapsulation utilisée par l’interface G0/1 de R1 ?
  • Quelle est l’adresse de la passerelle de R1 ?
  • Quelle est l’adresse de la passerelle IPv6 que les PCs utilisent ?
  • Comment visualiser le trajet des paquets IPv4 à partir du PC1 ?
  • Veuillez capturer et détailler le trafic qui permet l’autoconfiguration IPv6.
  • Quelles sont les commandes de diagnostic IPv6 propres à Windows.
  • Quelle est dans un IOS 15.6 l'algorithme de chiffrement par défaut des mots de passe ? Est-il sûr ?
Author image
Francois Goffinet est formateur Cisco Systems depuis 2002. Passionné des technologies des réseaux, de virtualisation et en nuage, Web et de cybersécurité souvent en Open Source ou Unix-Like, devops.