Objectifs de certification

ICND2 200-105

  • 1.3 Configurer, vérifier et dépanner les protocoles STP STP mode PVST+ et RPVST+, Sélection du bridge STP root

  • 1.4 Configurer, vérifier et dépanner les fonctionnalités STP optionnelles PortFast, BPDU guard

CCNA R&S 200-125

  • 2.6 Configurer, vérifier et dépanner les protocoles STP (STP mode PVST+ et RPVST+, Sélection du bridge STP root)

  • 2.7 Configurer, vérifier et dépanner les fonctionnalités STP optionnelles (PortFast, BPDU guard)


Lab Spanning-Tree et Rapid Spanning-tree Cisco

1. Présentation

Configuration du protocole Rapid PVST+, de PortFast et de la protection BPDU.

1.1. Topologie

1.2. Plan d’adressage

PériphériqueInterfaceAdresse IPMasque de sous-réseau
S1VLAN 99192.168.1.11255.255.255.0
S2VLAN 99192.168.1.12255.255.255.0
S3VLAN 99192.168.1.13255.255.255.0
PC1eth0192.168.0.2255.255.255.0
PC2eth0192.168.0.3255.255.255.0

1.3. Affectations des VLANs

VLANNom
10Utilisateur
99Administration

1.4. Objectifs

  • Partie 1 : création du réseau et configuration des paramètres de base du périphérique
  • Partie 2 : configuration de VLANs, du VLAN natifs et des trunks
  • Partie 3 : configuration du commutateur root et examen de la convergence PVST+
  • Partie 4 : configuration du protocole Rapid PVST+, de PortFast et de la protection BPDU, et examen de la convergence

1.5. Contexte/scénario

Le protocole PVST (Per-VLAN Spanning Tree) est un protocole propriétaire de Cisco. Par défaut, les commutateurs Cisco utilisent le protocole PVST. Le protocole Rapid PVST+ (IEEE 802.1w) est une version améliorée du protocole PVST+ et permet d’accélérer les calculs de l’algorithme Spanning-Tree et la convergence en réponse à des modifications de la topologie de couche 2. Le protocole Rapid PVST+ définit trois états de port, à savoir Discarded, Learning et Forwarding et offre beaucoup d’améliorations pour optimiser les performances du réseau.

Au cours de ce lab, vous êtes invité à configurer les commutateurs root principal et secondaire, à examiner la convergence PVST+, à configurer le protocole Rapid PVST+ et à comparer sa convergence par rapport à PVST+. Aussi, vous êtes invité à configurer des ports “Edge” pour passer directement à un état “Forwarding” à l’aide de “PortFast” et empêcher ces ports de retransférer des BDPUs à l’aide de la protection “BDPU Guard”.

1.6. Ressources requises

  • 3 commutateurs (vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Experimental Version 15.2(20170321:233949))
  • 2 PC (Centos 7 KVM ou Ubuntu Docker)
  • (Câbles de console pour configurer les périphériques Cisco IOS via les ports de console)
  • Câbles Ethernet conformément à la topologie

2. Création du réseau et configuration des paramètres de base du périphérique

Dans la cette partie, vous allez configurer la topologie du réseau et les paramètres de base, tels que l’adresse IP des interfaces, le routage statique, l’accès des périphériques et les mots de passe.

  1. Câblez le réseau conformément à la topologie.
    • Configurez les hôtes PC avec nmtui ou en éditant le fichier /etc/network/interfaces.
    • Initialisez et redémarrez les commutateurs, le cas échéant.
    • Configurez les paramètres de base pour chaque commutateur.
      • Désactivez la recherche DNS.
      • Configurez le nom du périphérique conformément à la topologie.
      • Attribuez testtest en tant que mots de passe de console et vty, puis activez la connexion.
      • Attribuez testtest comme mot de passe chiffré du mode d’exécution privilégié.
      • Configurez logging synchronous pour empêcher les messages de console d’interrompre la saisie de la commande.
      • Désactivez tous les ports du commutateur.
      • Copiez la configuration en cours en tant que configuration de démarrage.

3. Configuration des VLANs, du VLAN natif et des trunks

Dans cette partie, vous allez créer des VLANs, attribuer des ports de commutation aux VLANs, configurer des ports “trunk” et modifier le VLAN natif pour tous les commutateurs.

3.1. Création des VLANs.

Utilisez les commandes appropriées pour créer les VLANs 10 et 99 sur tous les commutateurs. Nommez le VLAN 10 User et le VLAN 99 Management.

S1(config)# vlan 10
S1(config-vlan)# name User
S1(config-vlan)# vlan 99
S1(config-vlan)# name Management
S2(config)# vlan 10
S2(config-vlan)# name User
S2(config-vlan)# vlan 99
S2(config-vlan)# name Management
S3(config)# vlan 10
S3(config-vlan)# name User
S3(config-vlan)# vlan 99
S3(config-vlan)# name Management

3.2. Activation des ports utilisateur en mode d’accès et attribuez les VLANs.

Pour S1 G1/0 et S3 G2/0, activez les ports, configurez-les en tant que ports d’accès et attribuez-les au VLAN 10.

S1(config)# interface G1/0
S1(config-if)# no shutdown
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S3(config)# interface G2/0
S3(config-if)# no shutdown
S3(config-if)# switchport mode access
S3(config-if)# switchport access vlan 10

3.3. Configuration des ports “trunk” et attribution au VLAN 99 natif.

Pour les ports “trunk” sur tous les commutateurs, activez les ports, configurez-les en tant que ports “trunk” et attribuez-les au VLAN 99 natif.

S1(config)# interface range G0/2,G0/3
S1(config-if-range)# no shutdown
S1(config-if-range)# switchport trunk encapsulation dot1q
S1(config-if-range)# switchport mode trunk
S1(config-if-range)# switchport trunk native vlan 99
S2(config)# interface range G0/1,G0/3
S2(config-if-range)# no shutdown
S2(config-if-range)# switchport trunk encapsulation dot1q
S2(config-if-range)# switchport mode trunk
S2(config-if-range)# switchport trunk native vlan 99
S3(config)# interface range G0/1,G0/2
S3(config-if-range)# no shutdown
S3(config-if-range)# switchport trunk encapsulation dot1q
S3(config-if-range)# switchport mode trunk
S3(config-if-range)# switchport trunk native vlan 99

3.4. Configuration de l’interface de gestion sur tous les commutateurs.

À l’aide du plan d’adressage, configurez l’interface de gestion de tous les commutateurs avec l’adresse IP appropriée.

S1(config)# interface vlan 99
S1(config-if)# ip address 192.168.1.11 255.255.255.0
S1(config-if)# no shutdown
S2(config)# interface vlan 99
S2(config-if)# ip address 192.168.1.12 255.255.255.0
S2(config-if)# no shutdown
S3(config)# interface vlan 99
S3(config-if)# ip address 192.168.1.13 255.255.255.0
S3(config-if)# no shutdown

3.5. Vérification des configurations et de la connectivité

Exécutez la commande show vlan brief sur tous les commutateurs pour vérifier que tous les VLAN sont enregistrés dans la table VLAN et que les ports corrects sont attribués.

S1# show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/0, Gi0/1, Gi1/1, Gi1/2
                                                Gi1/3, Gi2/0, Gi2/1, Gi2/2
                                                Gi2/3, Gi3/0, Gi3/1, Gi3/2
                                                Gi3/3
10   User                             active    Gi1/0
99   Management                       active    
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

S2#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/0, Gi0/2, Gi1/0, Gi1/1
                                                Gi1/2, Gi1/3, Gi2/0, Gi2/1
                                                Gi2/2, Gi2/3, Gi3/0, Gi3/1
                                                Gi3/2, Gi3/3
10   User                             active    
99   Management                       active    
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

S3#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/0, Gi0/3, Gi1/0, Gi1/1
                                                Gi1/2, Gi1/3, Gi2/1, Gi2/2
                                                Gi2/3, Gi3/0, Gi3/1, Gi3/2
                                                Gi3/3
10   User                             active    Gi2/0
99   Management                       active    
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Exécutez la commande show running-config sur tous les commutateurs pour vérifier l’ensemble des configurations.

  • Quel est le paramètre par défaut du mode STP sur les commutateurs Cisco ? Le mode STP par défaut est PVST+.
  • Vérifiez la connectivité entre PC1 et PC2. Votre requête ping a-t-elle abouti ?
  • En cas d’échec de votre requête ping, dépannez les configurations jusqu’à ce que le problème soit résolu.

4. Configuration du commutateur “root” et observation de la convergence de PVST+

Dans cette partie, vous allez déterminer le commutateur “root” par défaut dans le réseau, attribuer les commutateurs “root principal” et “root secondaire”. Veuillez exécuter la commande debug pour examiner la convergence de PVST+.

4.1. Identification du commutateur “root” actuel.

Quelle commande permet à un utilisateur de déterminer l’état du protocole STP d’un commutateur Cisco Catalyst pour tous les VLAN ?

show spanning-tree

Exécutez la commande sur les trois commutateurs pour trouver la réponse aux questions suivantes :

Remarque : il y a trois instances de Spanning-Tree sur chaque commutateur. La configuration par défaut du protocole STP sur les commutateurs Cisco est PVST+ crée une instance Spanning-Tree distincte pour chaque VLAN (le VLAN 1 et tout autre VLAN configuré par l’utilisateur).

  • Quelle est la priorité de pont du commutateur S1 pour VLAN 1 ? 32769
  • Quelle est la priorité de pont du commutateur S2 pour VLAN 1 ? 32769
  • Quelle est la priorité de pont du commutateur S3 pour VLAN 1 ? 32769
  • Quel commutateur est le commutateur root ? Les réponses peuvent varier. Dans cette configuration, il s’agit du commutateur S3.

Pourquoi ce commutateur a-t-il été sélectionné comme commutateur root ? Par défaut, Spanning-Tree sélectionne le commutateur root en fonction de la plus petite adresse MAC.

S1#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     004e.4157.7500
             Cost        4
             Port        4 (GigabitEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     004e.4192.8500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/2               Altn BLK 4         128.3    Shr
Gi0/3               Root FWD 4         128.4    Shr



VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     004e.4157.7500
             Cost        4
             Port        4 (GigabitEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     004e.4192.8500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/2               Altn BLK 4         128.3    Shr
Gi0/3               Root FWD 4         128.4    Shr
Gi1/0               Desg FWD 4         128.5    Shr



VLAN0099
  Spanning tree enabled protocol ieee
  Root ID    Priority    32867
             Address     004e.4157.7500
             Cost        4
             Port        4 (GigabitEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32867  (priority 32768 sys-id-ext 99)
             Address     004e.4192.8500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/2               Altn BLK 4         128.3    Shr
Gi0/3               Root FWD 4         128.4    Shr

S2#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     004e.4157.7500
             Cost        4
             Port        4 (GigabitEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     004e.4166.fe00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.2    Shr
Gi0/3               Root FWD 4         128.4    Shr



VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     004e.4157.7500
             Cost        4
             Port        4 (GigabitEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     004e.4166.fe00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.2    Shr
Gi0/3               Root FWD 4         128.4    Shr



VLAN0099
  Spanning tree enabled protocol ieee
  Root ID    Priority    32867
             Address     004e.4157.7500
             Cost        4
             Port        4 (GigabitEthernet0/3)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32867  (priority 32768 sys-id-ext 99)
             Address     004e.4166.fe00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.2    Shr
Gi0/3               Root FWD 4         128.4    Shr


S3#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     004e.4157.7500
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     004e.4157.7500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.2    Shr
Gi0/2               Desg FWD 4         128.3    Shr



VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     004e.4157.7500
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     004e.4157.7500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.2    Shr
Gi0/2               Desg FWD 4         128.3    Shr
Gi2/0               Desg FWD 4         128.9    Shr



VLAN0099
  Spanning tree enabled protocol ieee
  Root ID    Priority    32867
             Address     004e.4157.7500
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32867  (priority 32768 sys-id-ext 99)
             Address     004e.4157.7500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.2    Shr
Gi0/2               Desg FWD 4         128.3    Shr

4.2. Configuration du commutateur “root principal” et du commutateur “root secondaire” pour tous les VLAN existants.

Le fait qu’un commutateur “root” soit sélectionné en fonction de l’adresse MAC peut entraîner une configuration non optimale. Au cours de ces travaux pratiques, vous allez configurer le commutateur S2 comme commutateur “root principal” et le commutateur S1 comme commutateur “root secondaire”.

a. Configurez le commutateur S2 en tant que commutateur “root principal” de tous les VLANs existants.

S2(config)# spanning-tree vlan 1,10,99 root primary

b. Configurez le commutateur S1 en tant que commutateur “root secondaire” de tous les VLANs existants.

S1(config)# spanning-tree vlan 1,10,99 root secondary

Exécutez la commande show spanning-tree pour répondre aux questions suivantes :

  • Quelle est la priorité de pont de S1 pour VLAN 1 ? 28673
  • Quelle est la priorité de pont de S2 pour VLAN 1 ? 24577
  • Dans le réseau, quelle interface est en état de blocage ? L’interface G0/1 sur le commutateur S3
S1# show spanning-tree vlan 1

4.3. Modification de la topologie de couche 2 et observation la convergence.

Pour examiner la convergence de PVST+, vous allez créer une modification de la topologie de couche 2 tout en exécutant la commande debug pour surveiller les événements du protocole STP.

a. Saisissez la commande debug spanning-tree events en mode d’exécution privilégié sur le commutateur S3.

S3# debug spanning-tree events
Spanning Tree event debugging is on

b. Créez une modification de la topologie en désactivant l’interface G0/2 sur S3.

S3(config)# interface G0/2
S3(config-if)# shutdown
*Jun 27 09:09:18.917: STP: VLAN0001 new root port Gi0/1, cost 8
*Jun 27 09:09:18.917: STP: VLAN0001 Gi0/1 -> listening
*Jun 27 09:09:18.917: STP[1]: Generating TC trap for port GigabitEthernet0/2
*Jun 27 09:09:18.917: STP: VLAN0010 new root port Gi0/1, cost 8
*Jun 27 09:09:18.917: STP: VLAN0010 Gi0/1 -> listening
*Jun 27 09:09:18.917: STP[10]: Generating TC trap for port GigabitEthernet0/2
*Jun 27 09:09:18.917: STP: VLAN0099 new root port Gi0/1, cost 8
*Jun 27 09:09:18.917: STP: VLAN0099 Gi0/1 -> listening
*Jun 27 09:09:18.918: STP[99]: Generating TC trap for port GigabitEthernet0/2
S3(config-if)#
*Jun 27 09:09:20.891: %LINK-5-CHANGED: Interface GigabitEthernet0/2, changed state to administratively down
S3(config-if)#
*Jun 27 09:09:20.918: STP: VLAN0001 sent Topology Change Notice on Gi0/1
*Jun 27 09:09:20.918: STP: VLAN0010 sent Topology Change Notice on Gi0/1
*Jun 27 09:09:20.919: STP: VLAN0099 sent Topology Change Notice on Gi0/1
S3(config-if)#
*Jun 27 09:09:21.891: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to down
S3(config-if)#
*Jun 27 09:09:33.917: STP: VLAN0001 Gi0/1 -> learning
*Jun 27 09:09:33.917: STP: VLAN0010 Gi0/1 -> learning
*Jun 27 09:09:33.917: STP: VLAN0099 Gi0/1 -> learning
S3(config-if)#
S3(config-if)#
S3(config-if)#
S3(config-if)#
*Jun 27 09:09:48.917: STP[1]: Generating TC trap for port GigabitEthernet0/1
*Jun 27 09:09:48.917: STP: VLAN0001 Gi0/1 -> forwarding
*Jun 27 09:09:48.917: STP[10]: Generating TC trap for port GigabitEthernet0/1
*Jun 27 09:09:48.918: STP: VLAN0010 sent Topology Change Notice on Gi0/1
*Jun 27 09:09:48.918: STP: VLAN0010 Gi0/1 -> forwarding
*Jun 27 09:09:48.918: STP[99]: Generating TC trap for port GigabitEthernet0/1
*Jun 27 09:09:48.918: STP: VLAN0099 Gi0/1 -> forwarding

Avant de poursuivre, utilisez les résultats debug pour vérifier que tous les VLAN sur G0/1 ont atteint un état de “Forwarding”, puis exécutez la commande no debug spanning-tree events pour interrompre l’affichage debug.

Par quels états de port passe chaque VLAN sur G0/1 lors de la convergence du réseau ? “Listening”, “Learning” et “Forwarding”

À l’aide de l’horodatage du premier et du dernier message de débogage STP, calculez le temps (à la seconde près) qu’il a fallu au réseau pour converger.

Remarque : le format de l’horodatage de débogage est date hh.mm.ss:ms.

Les réponses peuvent varier légèrement, mais le temps de convergence doit être de 30 secondes environ.

5. Configuration du protocole Rapid PVST+, PortFast et de la protection BPDU, et examen de la convergence

Dans cette partie, vous allez configurer le protocole Rapid PVST+ sur tous les commutateurs. Vous allez configurer PortFast et la protection BPDU sur tous les ports d’accès, puis exécuter la commande debug pour examiner la convergence du protocole Rapid PVST+.

5.1. Configuration du protocole Rapid PVST+.

a. Configurez S1 pour le protocole Rapid PVST+.

S1(config)# spanning-tree mode rapid-pvst

b. Configurez S2 et S3 pour le protocole Rapid PVST+.

S2(config)# spanning-tree mode rapid-pvst
S3(config)# spanning-tree mode rapid-pvst

c. Vérifiez les configurations en exécutant la commande show running-config | include spanning-tree mode.

S1# show running-config | include spanning-tree mode
spanning-tree mode rapid-pvst
S2# show running-config | include spanning-tree mode
spanning-tree mode rapid-pvst
S3# show running-config | include spanning-tree mode
spanning-tree mode rapid-pvst

5.2. Configuration de “PortFast” et de la protection BPDU sur les ports d’accès.

“PortFast” est une fonctionnalité de Spanning-Tree qui fait passer un port directement à un état de “Forwarding” dès qu’il est activé. Cette fonctionnalité est utile pour connecter les hôtes terminaux afin qu’ils puissent commencer à communiquer directement sur le VLAN, plutôt que de patienter sur les délais Spanning-Tree. Pour empêcher les ports qui sont configurés avec “PortFast” de réacheminer des BPDUs, ce qui pourrait modifier la topologie de Spanning-Tree, la protection BPDU peut être activée. À la réception d’une BPDU, la protection BPDU désactive un port configuré avec “PortFast”.

a. Configurez l’interface G1/0 sur S1 avec PortFast.

S1(config)# interface G1/0
S1(config-if)# spanning-tree portfast

b. Configurez l’interface G1/0 sur S1 avec la protection BPDU.

S1(config)# interface G1/0
S1(config-if)# spanning-tree bpduguard enable

c. Configurez globalement tous les ports non trunk sur le commutateur S3 avec PortFast.

S3(config)# spanning-tree portfast default

d. Configurez globalement tous les ports PortFast non trunk sur le commutateur S3 avec la protection BPDU.

S3(config)# spanning-tree portfast bpduguard default

5.3. Observation de la convergence du protocole Rapid PVST+.

a. Saisissez la commande debug spanning-tree events en mode d’exécution privilégié sur le commutateur S3.

b. Créez une modification de la topologie en activant l’interface G0/2 sur le commutateur S3.

S3(config)# interface G0/2
S3(config-if)# no shutdown

À l’aide de l’horodatage du premier et du dernier message de débogage RSTP, calculez le temps qu’il a fallu au réseau pour converger.

Les réponses peuvent varier légèrement, mais le temps de convergence doit être inférieur à une seconde.

  1. Quel est le principal avantage de l’utilisation du protocole Rapid PVST+ ? Le protocole Rapid PVST+ réduit considérablement le temps de la convergence de couche 2 par rapport à PVST+.
  2. En quoi la configuration d’un port avec “PortFast” permet-elle une convergence plus rapide ? PortFast permet à un port d’accès de passer directement à un état de Forwarding, ce qui réduit le temps de la convergence de couche 2.

  3. Quel type de protection offre la protection BPDU ? La protection BPDU protège le domaine STP en désactivant les ports d’accès qui reçoivent une BPDU. Les BPDU peuvent être utilisées dans une attaque par déni de service qui modifie le commutateur root d’un domaine et oblige un nouveau calcul STP.
*Jun 27 09:19:45.965: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
*Jun 27 09:19:46.965: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to up
*Jun 27 09:19:47.108: RSTP(1): initializing port Gi0/2
*Jun 27 09:19:47.108: RSTP(1): Gi0/2 is now designated
*Jun 27 09:19:47.108: RSTP(10): initializing port Gi0/2
*Jun 27 09:19:47.108: RSTP(10): Gi0/2 is now designated
*Jun 27 09:19:47.108: RSTP(99): initializing port Gi0/2
*Jun 27 09:19:47.109: RSTP(99): Gi0/2 is now designated
*Jun 27 09:19:47.109: RSTP(10): updt roles, received superior bpdu on Gi0/2
*Jun 27 09:19:47.109: RSTP(10): Gi0/2 is now root port
*Jun 27 09:19:47.109: RSTP(10): Gi0/1 blocked by re-root
*Jun 27 09:19:47.109: RSTP(10): syncing port Gi2/0
*Jun 27 09:19:47.109: RSTP(10): Gi0/1 is now alternate
*Jun 27 09:19:47.109: RSTP(99): updt roles, received superior bpdu on Gi0/2
*Jun 27 09:19:47.109: RSTP(99): Gi0/2 is now root port
*Jun 27 09:19:47.109: RSTP(99): Gi0/1 blocked by re-root
*Jun 27 09:19:47.109: RSTP(99): Gi0/1 is now alternate
*Jun 27 09:19:47.109: RSTP(1): updt roles, received superior bpdu on Gi0/2
*Jun 27 09:19:47.110: RSTP(1): Gi0/2 is now root port
*Jun 27 09:19:47.110: RSTP(1): Gi0/1 blocked by re-root
*Jun 27 09:19:47.110: RSTP(1): Gi0/1 is now alternate
*Jun 27 09:19:47.116: RSTP(10): transmitting a proposal on Gi2/0
*Jun 27 09:19:47.117: STP[1]: Generating TC trap for port GigabitEthernet0/2
S3(config-if)#
*Jun 27 09:19:47.117: STP[10]: Generating TC trap for port GigabitEthernet0/2
*Jun 27 09:19:47.118: STP[99]: Generating TC trap for port GigabitEthernet0/2
*Jun 27 09:19:47.124: RSTP(10): transmitting a proposal on Gi2/0
*Jun 27 09:19:47.181: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:19:49.182: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:19:51.183: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
S3(config-if)#
S3(config-if)#
*Jun 27 09:19:53.184: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:19:55.186: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:19:57.188: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:19:59.190: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:20:01.191: RSTP(10): transmitting a proposal on Gi2/0
*Jun 27 09:20:02.109: RSTP(10): Gi2/0 fdwhile Expired
S3(config-if)#
*Jun 27 09:20:03.193: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:20:05.195: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:20:07.196: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:20:09.197: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:20:11.199: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
*Jun 27 09:20:13.200: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#
S3(config-if)#
S3(config-if)#
S3(config-if)#
*Jun 27 09:20:15.201: RSTP(10): transmitting a proposal on Gi2/0
S3(config-if)#^Z
*Jun 27 09:20:17.050: %SYS-5-CONFIG_I: Configured from console by console
*Jun 27 09:20:17.109: RSTP(10): Gi2/0 fdwhile Expired
S3#undebug all
All possible debugging has been turned off
S3#

6. Fichiers de configuration de la topologie

  • Partie 1 : création du réseau et configuration des paramètres de base du périphérique
  • Partie 2 : configuration de VLAN, de VLAN natifs et de “trunks”

6.1. Configuration de S1

configure terminal
hostname S1
ip domain-name lab.com
enable secret testtest
username root secret testtest
line con 0
 logging synchronous
line vty 0 4
 login local
no ip routing
spanning-tree mode pvst
interface range G0/0-3,G1/0-3,G2/0-3,G3/0-3
 shutdown
 vlan 10
  name User
 vlan 99
  name Management
interface vlan 99
 ip add 192.168.1.11 255.255.255.0
 no shutdown
interface G1/0
  no shutdown
  switchport mode access
  switchport access vlan 10
interface range G0/2,G0/3
  no shutdown
  switchport trunk encapsulation dot1q
  switchport mode trunk
  switchport trunk native vlan 99
  end
wr

6.2. Configuration de S2

configure terminal
hostname S2
ip domain-name lab.com
enable secret testtest
username root secret testtest
line con 0
 logging synchronous
line vty 0 4
 login local
no ip routing
spanning-tree mode pvst
interface range G0/0-3,G1/0-3,G2/0-3,G3/0-3
 shutdown
 vlan 10
  name User
 vlan 99
  name Management
interface vlan 99
 ip add 192.168.1.12 255.255.255.0
 no shutdown
interface range G0/1,G0/3
  no shutdown
  switchport trunk encapsulation dot1q
  switchport mode trunk
  switchport trunk native vlan 99
  end
wr

6.3. Configuration de S3

configure terminal
hostname S3
ip domain-name lab.com
enable secret testtest
username root secret testtest
line con 0
 logging synchronous
line vty 0 4
 login local
no ip routing
spanning-tree mode pvst
interface range G0/0-3,G1/0-3,G2/0-3,G3/0-3
 shutdown
 vlan 10
  name User
 vlan 99
  name Management
interface vlan 99
 ip add 192.168.1.13 255.255.255.0
 no shutdown
interface G2/0
  no shutdown
  switchport mode access
  switchport access vlan 10
interface range G0/1,G0/2
  no shutdown
  switchport trunk encapsulation dot1q
  switchport mode trunk
  switchport trunk native vlan 99
  end
wr

6.4. PC1

hostnamectl set-hostname PC1
nmcli c mod eth0 ipv4.addresses 192.168.0.2/24
nmcli c mod eth0 ipv4.method manual
nmcli c up  eth0

6.5. PC2

hostnamectl set-hostname PC2
nmcli c mod eth0 ipv4.addresses 192.168.0.3/24
nmcli c mod eth0 ipv4.method manual
nmcli c up  eth0

Laisser un commentaire