Objectifs de certification

CCNA 200-301

  • 3.5 Décrire le but des protocoles de redondance du premier saut (first hop redundancy protocol)

  • 2.5 Décrire la nécessité et les operations de base de Rapid PVST+ Spanning Tree Protocol

    • 2.5.a Root port, root bridge (primary/secondary), et les autres noms de port
    • 2.5.b Port states (forwarding/blocking)
    • 2.5.c Avantages PortFast
  • 2.1 Configurer et vérifier les VLANs (normal range) couvrant plusieurs switches

    • 2.1.a Access ports (data et voice)
    • 2.1.b Default VLAN
    • 2.1.c Connectivity
  • 2.2 Configurer et vérifier la connectivité interswitch

    • 2.2.a Trunk ports
    • 2.2.b 802.1Q
    • 2.2.c Native VLAN
  • 4.6 Configurer et vérifier DHCP client et relay


Lab Disponibilité dans le LAN RSTP sans boucle avec HSRP

Cet exercice consiste à se passer de la boucle Spanning-tree par une liaison IP dans la couche Distribution à des fins de performance, ce qui nécessitera de ne pas étaler les Vlans dans la couche Access. La couche Distribution offre toujours un service de passerelle et DHCP redondants.

1. Enoncé

A des fins de performance, on propose ici de couper la boucle Spanning-Tree (sans le désactiver) entre DS1 et DS2 avec une liaison de couche 3 adressée en IPv4 et en IPv6.

1.1. Topologie sans redondance de passerelle HSRP

Topologie sans redondance de passerelle HSRP

1.2. Topologie avec redondance de passerelle HSRP

Topologie avec redondance de passerelle HSRP

2. Discussion

En remplaçant le Trunk Vlan (L2) entre DS1 et DS2 (Po3, g0/2,g1/2) par une liaison L3 (172.16.212.0/24-fd00:1ab:d2d0:1::/64), les Vlans ne doivent pas s’étaler à travers la couche Access. Les Vlans seront uniquement joignables entre eux grâce au routage IP des commutateurs de couche Distribution.

DS1 et DS2 restent toutefois les passerelles potentielles pour la couche Access. Si l’une d’elles tombe, la passerelle alternative ne recevra plus d’annonces HSRP via un des commutateurs de couche Access. Les trafic vers un Vlan non-local au commutateur, nécessairement distant, sera pris en charge par la nouvelle passerelle.

Le but de cette proposition de conception est d’éliminer les délais Spanning-Tree entre la couche Access et la couche Distribution sans désactiver le protocole tant qu’il est possible de localiser les Vlans sur un commutateur ou sur un “Stack” de commutateurs.

Mais quelle est l’utilité de la liaison entre DS1 et DS2 ? Assurément, elle n’intervient plus dans le trafic inter-vlans de la topologie. Elle servira probablement à transférer le trafic via un chemin optimal vers des destinations de la couche Core.

3. Configuration

Voici la configuration pour remplacer le Trunk Etherchannel entre DS1 et DS2 (Po3, g0/2,g1/2) par une liaison L3 (172.16.212.0/24-fd00:1ab:d2d0:1::/64).

Sur DS1 :

interface GigabitEthernet0/2
 shutdown
 no switchport
 no channel-group 3 mode desirable
 channel-group 3 mode on
 no shutdown
interface GigabitEthernet1/2
 shutdown
 no switchport
 no channel-group 3 mode desirable
 channel-group 3 mode on
 no shutdown
interface Port-channel3
 shutdown
 no switchport
 ip address 172.16.212.1 255.255.255.0
 ipv6 address fd00:1ab:d2d0:1::1/64
 ipv6 address fe80::d:2 link-local
 no shutdown

Sur DS2 :

interface GigabitEthernet0/2
 shutdown
 no switchport
 no channel-group 3 mode desirable
 channel-group 3 mode on
 no shutdown
interface GigabitEthernet1/2
 shutdown
 no switchport
 no channel-group 3 mode desirable
 channel-group 3 mode on
 no shutdown
interface Port-channel3
 shutdown
 no switchport
 ip address 172.16.224.2 255.255.255.0
 ipv6 address fd00:1ab:d2d0:1::2/64
 ipv6 address fe80::d:3 link-local
 no shutdown

Laisser un commentaire