Objectifs de certification

CCNA R&S 200-125

  • 2.9 Configurer, vérifier et dépanner EtherChannel Couche 2/Couche 3 (Static, PAGP, LACP)

  • 2.6 Configurer, vérifier et dépanner les protocoles STP (STP mode PVST+ et RPVST+, Sélection du bridge STP root)

  • 2.7 Configurer, vérifier et dépanner les fonctionnalités STP optionnelles (PortFast, BPDU guard)

  • 2.4 Configurer, vérifier et dépanner des VLANs normal/extended range recouvrants plusieurs commutateurs (Access ports data and voice, Default VLAN)

  • 2.5 Configurer, vérifier et dépanner l’inter-connectivité entre les commutateurs (Trunk ports, Ajouter et retirer des VLANs sur un trunk, DTP, VTP v1&v2 et 802.1Q, Native VLAN)

  • 5.3 Configurer et vérifier DHCP sur un routeur sauf les réservations statiques (Server, Relay, Client, TFTP, DNS, and gateway options)

  • 5.4 Dépanner des problèmes de connectivité DHCP client et routeur

  • 1.15 Comparer et mettre en contraste les types d’adresse IPv6 Global unicast, Unique local, Link local, Multicast, Modified EUI 64, Autoconfiguration, Anycast

  • 1.14 Configurer, vérifier le service IPv6 Stateless Address Auto Configuration

CCNA 200-301

  • 2.4 Configurer et vérifier (Layer 2/Layer 3) EtherChannel (LACP)

  • 2.5 Décrire la nécessité et les operations de base de Rapid PVST+ Spanning Tree Protocol

    • 2.5.a Root port, root bridge (primary/secondary), et les autres noms de port
    • 2.5.b Port states (forwarding/blocking)
    • 2.5.c Avantages PortFast
  • 3.5 Décrire le but des protocoles de redondance du premier saut (first hop redundancy protocol)

  • 2.1 Configurer et vérifier les VLANs (normal range) couvrant plusieurs switches

    • 2.1.a Access ports (data and voice)
    • 2.1.b Default VLAN
    • 2.1.c Connectivity
  • 2.2 Configurer et vérifier la connectivité interswitch

    • 2.2.a Trunk ports
    • 2.2.b 802.1Q
    • 2.2.c Native VLAN
  • 4.6 Configurer et vérifier DHCP client et relay


Lab répartition de charge avec Rapid Spanning-Tree

L’objectif de cet exercice de laboratoire sur le protocole Rapid Spanning-Tree est d’éprouver ses capacités de répartition de la charge des VLANs sur des liaisons Trunk alternatives tout en assurant sa mission de reprise suite à une rupture d’une liaison entre un commutateur de couche “Access” et un commutateur de couche “Distribution”. Nous verrons que la solution comprend encore un point unique de rupture avec la passerelle par défaut des VLANs dans la couche “Distribution”.

1. Enoncé

1.1. Topologie sans redondance de passerelle

Topologie RSTP sans redondance de passerelle

1.2. VLANs

VLANPorts Access (AS1 et AS2) plage d’adressePasserelle par défaut 
VLAN 10g2/0172.16.10.0/24172.16.10.252
VLAN 20g2/1172.16.20.0/24172.16.20.253
VLAN 30g2/2172.16.30.0/24172.16.30.252
VLAN 40g2/3172.16.40.0/24172.16.40.253
VLAN 99VLAN natifManagement 

1.3. Ports Etherchannel et Trunk VLANs

PortChannelports physiquesCommutateurs
po1 g0/0,g1/0AS1 - DS1
po2 g0/1,g1/1AS1 - DS2
po3 g0/2,g1/2DS1 - DS2
po4 g0/0,g1/0AS2 - DS2
po5 g0/1,g1/1AS2 - DS1

1.4. Spanning-Tree

VLANsDS1DS2
VLANs 1,10,30,99root primaryroot secondary
VLANs 20,40root secondaryroot primary

1.5.Plan d’adressage

CommutateurInterfaceAdresse IPv4Adresse(s) IPv6
DS1VLAN10172.16.10.252/24fd00:1ab:10::1/64
DS1VLAN20172.16.20.252/24fd00:1ab:20::1/64
DS1VLAN30172.16.30.252/24fd00:1ab:30::1/64
DS1VLAN40172.16.40.252/24fd00:1ab:40::1/64
DS2VLAN10172.16.10.253/24fd00:1ab:10::2/64
DS2VLAN20172.16.20.253/24fd00:1ab:20::2/64
DS2VLAN30172.16.30.253/24fd00:1ab:30::2/64
DS2VLAN40172.16.40.253/24fd00:1ab:40::2/64

1.6. Ressources requises

  • 4 commutateurs (vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Experimental Version 15.2(20170321:233949))
  • 8 PCs (Centos 7 KVM ou Ubuntu Docker)
  • (Câbles de console pour configurer les périphériques Cisco IOS via les ports de console)
  • Câbles Ethernet conformément à la topologie

1.7. Explication

Dans cette topologie, les VLANs sont distribués sur toute la couche d’accès. On trouve des domaines L2, des “domaines de Broadcast” au sein des couches Access et Distribution. Dans cet exercice, on apprendra à configurer Spanning-Tree de façon à repartir le trafic de certains VLANs sur une liaison et le trafic d’autres sur la liaison qui serait normalement bloquée par Spanning-Tree. En cas de rupture d’une des liaisons, Spanning-tree offre un chemin alternatif via le second commutateur de couche Distribution.

En désignant l’un des commutateurs comme “root primary” pour certains VLANs et “root secondary” pour d’autres, et inversément pour l’autre commutateur de Distribution, on arrive à répartir la charge du trafic sur les Trunks et à offrir un mécanisme de reprise sur erreur. Mais on verra que Spanning-Tree ne prémunit pas d’une rupture de passerelle par défaut dans la couche Distribution et que le délai du standard même dans sa version rapide peut être encore trop lent.

1.8. Vue simplifiée

Si on simplifie la vue de la topologie avec un seul commutateur Access, le Trunk Po1 transfère le trafic des VLANs 10, 30 et 99. DS1 est “root primary” pour ces VLANs. Le port Po2 transfère le trafic des VLANs 20 et 40. DS2 est “root primary” pour ces VLANs.

1.9. Redondance Spanning-Tree

Grâce à Spanning-Tree, en cas de rupture sur la liaison Po1 de la topologie, le trafic des VLANs 10, 30 et 99 sera transféré via le commutateur “root secondary” alternatif.

1.10. Absence de redondnance de passerelle

Toutefois, si le commutateur de Distribution principal qui faisait office de seule passerelle L3 tombe totalement ou si celui-ci perd ses routes, Spanning-Tree reste impuissant.

2. Mise en place de la topologie Spanning-Tree

Au préalable, on ira nommer les périphériques (avec commande hostname en configuration globale). Tout autre configuration personnalisée sur les consoles et leur accès est bienvenue (logging synchronous sur les consoles par exemple, un enable secret, etc.).

AS1 et AS2 sont des commutateurs L2. On désactivera le routage IP sur certaines plateformes.

(config)#no ip routing

2.1. Création des VLANs

Utilisez les commandes appropriées pour créer les VLANs 10, 20, 30, 40 et 99 sur tous les commutateurs. Nommez le VLAN 99 Management.

vlan 10
vlan 20
vlan 30
vlan 40
vlan 99
 name management

2.2. Configuration des ports “Access”

Pour AS1 et AS2, activez les ports des stations de travail, configurez-les en tant que ports Access (avec portfast et bpduguard) et attribuez-les à leur VLAN.

interface g2/0
 switchport mode access
 switchport access vlan 10
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/1
 switchport mode access
 switchport access vlan 20
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/2
 switchport mode access
 switchport access vlan 30
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/3
 switchport mode access
 switchport access vlan 40
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown

2.3. Configuration des ports “trunk” et VLAN 99 natif.

Pour les ports “trunk” sur tous les commutateurs, activez les ports physiques et les PortChannels, configurez-les en tant que ports “trunk” et configurez le VLAN 99 natif.

DS1

interface range g0/0,g1/0
 shutdown
 channel-group 1 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 shutdown
 channel-group 5 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/2,g1/2
 shutdown
 channel-group 3 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po1,po3,po5
 shutdown
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown

DS2

interface range g0/0,g1/0
 shutdown
 channel-group 4 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 shutdown
 channel-group 2 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/2,g1/2
 shutdown
 channel-group 3 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po2,po3,po4
 shutdown
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown

AS1

interface range g0/0,g1/0
 shutdown
 channel-group 1 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 shutdown
 channel-group 2 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po1,po2
 shutdown
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown

AS2

interface range g0/0,g1/0
 shutdown
 channel-group 4 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 shutdown
 channel-group 5 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po4,po5
 shutdown
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown

2.4. Configuration de la répartition de charge PVRSTP+

Rapid Spanning-Tree s’active en configuration globale avec la commande spanning-tree mode rapid-pvst. DS1 est root primary pour les VLANs 1,10,30,99. Il est root secondary pour les VLANs 20,40. DS2 est root primary pour les VLANs 20,40. Il est root secondary pour les VLANs 1,10,30,99.

DS1

spanning-tree mode rapid-pvst
spanning-tree vlan 1,10,30,99 root primary
spanning-tree vlan 20,40 root secondary

DS2

spanning-tree mode rapid-pvst
spanning-tree vlan 20,40 root primary
spanning-tree vlan 1,10,30,99 root secondary

AS1 et AS2

spanning-tree mode rapid-pvst

2.5. Vérification répartition de charge PVRSTP

Sur AS1, pour le VLAN 10 :

  • Le port po1 qui connecte DS1 est en état FWD (rôle root)

  • Le port po2 qui connecte DS2 est en état BLK (rôle Altn)

AS1#show spanning-tree vlan 10 active

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0c66.f9fe.3e00
             Cost        3
             Port        65 (Port-channel1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0c66.f90a.5400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi2/0               Desg FWD 4         128.9    P2p Edge
Po1                 Root FWD 3         128.65   P2p
Po2                 Altn BLK 3         128.66   P2p


Sur AS1, pour le VLAN 20 :

  • Le port po2 qui connecte DS2 est état FWD (rôle root)

  • Le port po1 qui connecte DS1 est en état BLK (rôle Altn)

AS1#show spanning-tree vlan 20 active

VLAN0020
  Spanning tree enabled protocol rstp
  Root ID    Priority    24596
             Address     0c66.f90f.4900
             Cost        3
             Port        66 (Port-channel2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     0c66.f90a.5400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi2/1               Desg FWD 4         128.10   P2p Edge
Po1                 Altn BLK 3         128.65   P2p
Po2                 Root FWD 3         128.66   P2p

On trouvera une situation similaire à observer sur le commutateur AS2.

3. Configuration des passerelles IPv4 et IPv6 et du service DHCP

3.1. Configuration IPv4 des passerelles DS1 et DS2

À l’aide du plan d’adressage, configurez l’interface de gestion de tous les commutateurs avec l’adresse IPv4 appropriée.

DS1

interface vlan 10
 ip address 172.16.10.252 255.255.255.0
 no shutdown
interface vlan 20
 ip address 172.16.20.252 255.255.255.0
 no shutdown
interface vlan 30
 ip address 172.16.30.252 255.255.255.0
 no shutdown
interface vlan 40
 ip address 172.16.40.252 255.255.255.0
 no shutdown
ip routing

DS2

interface vlan 10
 ip address 172.16.10.253 255.255.255.0
 no shutdown
interface vlan 20
 ip address 172.16.20.253 255.255.255.0
 no shutdown
interface vlan 30
 ip address 172.16.30.253 255.255.255.0
 no shutdown
interface vlan 40
 ip address 172.16.40.253 255.255.255.0
 no shutdown
ip routing

3.2. Configuration IPv6 des passerelles DS1 et DS2

À l’aide du plan d’adressage, configurez l’interface de gestion de tous les commutateurs avec l’adresse IPv6 appropriée.

DS1

interface vlan 10
 ipv6 address fd00:1ab:10::1/64
 no shutdown
interface vlan 20
 ipv6 address fd00:1ab:20::1/64
 no shutdown
interface vlan 30
 ipv6 address fd00:1ab:30::1/64
 no shutdown
interface vlan 40
 ipv6 address fd00:1ab:40::1/64
 no shutdown
ipv6 unicast-routing

DS2

interface vlan 10
 ipv6 address fd00:1ab:10::2/64
 no shutdown
interface vlan 20
 ipv6 address fd00:1ab:20::2/64
 no shutdown
interface vlan 30
 ipv6 address fd00:1ab:30::2/64
 no shutdown
interface vlan 40
 ipv6 address fd00:1ab:40::2/64
 no shutdown
ipv6 unicast-routing

3.3. Configuration du service DHCP

Répartition de l’attribution des plages.

DS1 Serveur DHCP

ip dhcp pool VLAN10
 network 172.16.10.0 255.255.255.0
 default-router 172.16.10.252
ip dhcp excluded-address 172.16.10.50 172.16.10.254
ip dhcp pool VLAN20
 network 172.16.20.0 255.255.255.0
 default-router 172.16.20.253
ip dhcp excluded-address 172.16.20.50 172.16.20.254
ip dhcp pool VLAN30
 network 172.16.30.0 255.255.255.0
 default-router 172.16.30.252
ip dhcp excluded-address 172.16.30.50 172.16.30.254
ip dhcp pool VLAN40
 network 172.16.40.0 255.255.255.0
 default-router 172.16.40.253
ip dhcp excluded-address 172.16.40.50 172.16.40.254

DS2 Serveur DHCP

ip dhcp pool VLAN10
 network 172.16.10.0 255.255.255.0
 default-router 172.16.10.252
ip dhcp excluded-address 172.16.10.1 172.16.10.50
ip dhcp excluded-address 172.16.10.100 172.16.10.255
ip dhcp pool VLAN20
 network 172.16.20.0 255.255.255.0
 default-router 172.16.20.253
ip dhcp excluded-address 172.16.20.1 172.16.20.50
ip dhcp excluded-address 172.16.20.100 172.16.20.254
ip dhcp pool VLAN30
 network 172.16.30.0 255.255.255.0
 default-router 172.16.30.252
ip dhcp excluded-address 172.16.30.1 172.16.30.50
ip dhcp excluded-address 172.16.30.100 172.16.30.254
ip dhcp pool VLAN40
 network 172.16.40.0 255.255.255.0
 default-router 172.16.40.253
ip dhcp excluded-address 172.16.40.1 172.16.40.50
ip dhcp excluded-address 172.16.40.100 172.16.40.254

Vérification DHCP

Sur DS1 et sur DS2

DS2#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address      Client-ID/ 		Lease expiration 	Type       State      Interface
		Hardware address/
		User name
172.16.10.51    01ba.3be7.038b.79       Jul 06 2018 06:00 PM    Automatic  Active     Vlan10
172.16.10.52    01e2.c252.d5c2.56       Jul 06 2018 06:00 PM    Automatic  Active     Vlan10
172.16.20.51    019a.1e49.ba50.0d       Jul 06 2018 06:00 PM    Automatic  Active     Vlan20
172.16.20.52    01e6.3846.0182.d8       Jul 06 2018 06:00 PM    Automatic  Active     Vlan20
172.16.30.51    0126.f314.aa91.d8       Jul 06 2018 06:00 PM    Automatic  Active     Vlan30
172.16.30.52    01fe.81e0.bc43.9f       Jul 06 2018 06:00 PM    Automatic  Active     Vlan30
172.16.40.51    0122.6cf3.407a.c4       Jul 06 2018 06:00 PM    Automatic  Active     Vlan40
172.16.40.52    012a.94ef.5110.38       Jul 06 2018 06:00 PM    Automatic  Active     Vlan40

Pour afficher la configuration du service DHCP :

show run | section dhcp

3.5. Diagnostic de connectivité sur les commutateurs

show etherchannel summary
!
show etherchannel port-channel
!
show vlan brief
!
show spanning-tree vlan 10 active
!
show interface trunk
!
show interface switchport
!
show run all | include ip routing
!
show ip interface brief

3.6. Configuration et vérification sur les hôtes terminaux

ifconfig eth0 | grep inet
route
for x in 10 20 30 40 ; do ping -c 1 172.16.$x.252 ; arp -a; done

4. Vérification de la redondance STP

Sur base de :

  • un ping continu d’un PC vers sa passerelle par défaut,
  • un ping continu d’un PC vers un PC d’un autre VLAN.

Deux épreuves :

  • Rupture de liaison.
  • Rupture de passerelle.

4.1. Épreuves

Ping continu d’un PC du VLAN 10 vers sa passerelle.

root@PC1:~# ping 172.16.10.252

4.2. Rupture de liaison

Rompre la liaison entre AS1 et DS1.

interface po1
 shutdown

En faisant tomber l’interface po1 sur DS1, le délai éprouvé est celui de RSTP. La passerelle du VLAN 10 est maintenant joignable via chemin sous-optimal par DS2.

Quel est le délai approximatif de reprise de Rapid Spanning-Tree en se basant sur un test ICMP de bout de bout ?

Remonter l’interface po1 de DS1.

interface po1
 no shutdown

4.2. Rupture d’une passerelle

En faisant tomber une passerelle, plus aucun trafic vers un autre réseau n’est possible pour les clients du réseau qui l’utilisaient. Un protocole de redondance de passerelle tel que HSRP ou VRRP pourrait être intéressant à déployer …

5. Fichiers de configuration VLANs, Trunking, Etherchannel, Rapid Spanning-Tree, SVI IPv4/IPv6 et DHCP

DS1

hostname DS1
!
interface range g0/0-3,g1/0-3,g2/0-3,g3/0-3
 shutdown
!
vlan 10
vlan 20
vlan 30
vlan 40
vlan 99
 name management
!
spanning-tree mode rapid-pvst
spanning-tree vlan 1,10,30,99 root primary
spanning-tree vlan 20,40 root secondary
!
interface range g0/0,g1/0
 channel-group 1 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 channel-group 5 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/2,g1/2
 channel-group 3 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po1,po3,po5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
!
interface vlan 10
 ip address 172.16.10.252 255.255.255.0
 ipv6 address fd00:1ab:10::1/64
 no shutdown
interface vlan 20
 ip address 172.16.20.252 255.255.255.0
 ipv6 address fd00:1ab:20::1/64
 no shutdown
interface vlan 30
 ip address 172.16.30.252 255.255.255.0
 ipv6 address fd00:1ab:30::1/64
 no shutdown
interface vlan 40
 ip address 172.16.40.252 255.255.255.0
 ipv6 address fd00:1ab:40::1/64
 no shutdown
ip routing
ipv6 unicast-routing
!
ip dhcp pool VLAN10
 network 172.16.10.0 255.255.255.0
 default-router 172.16.10.252
ip dhcp excluded-address 172.16.10.50 172.16.10.254
ip dhcp pool VLAN20
 network 172.16.20.0 255.255.255.0
 default-router 172.16.20.253
ip dhcp excluded-address 172.16.20.50 172.16.20.254
ip dhcp pool VLAN30
 network 172.16.30.0 255.255.255.0
 default-router 172.16.30.252
ip dhcp excluded-address 172.16.30.50 172.16.30.254
ip dhcp pool VLAN40
 network 172.16.40.0 255.255.255.0
 default-router 172.16.40.253
ip dhcp excluded-address 172.16.40.50 172.16.40.254

DS2

hostname DS2
!
interface range g0/0-3,g1/0-3,g2/0-3,g3/0-3
 shutdown
!
vlan 10
vlan 20
vlan 30
vlan 40
vlan 99
 name management
!
spanning-tree mode rapid-pvst
spanning-tree vlan 20,40 root primary
spanning-tree vlan 1,10,30,99 root secondary
!
interface range g0/0,g1/0
 channel-group 4 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 channel-group 2 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/2,g1/2
 channel-group 3 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po2,po3,po4
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
!
interface vlan 10
 ip address 172.16.10.253 255.255.255.0
 ipv6 address fd00:1ab:10::2/64
 no shutdown
interface vlan 20
 ip address 172.16.20.253 255.255.255.0
 ipv6 address fd00:1ab:20::2/64
 no shutdown
interface vlan 30
 ip address 172.16.30.253 255.255.255.0
 ipv6 address fd00:1ab:30::2/64
 no shutdown
interface vlan 40
 ip address 172.16.40.253 255.255.255.0
 ipv6 address fd00:1ab:40::2/64
 no shutdown
ip routing
ipv6 unicast-routing
!
ip dhcp pool VLAN10
 network 172.16.10.0 255.255.255.0
 default-router 172.16.10.252
ip dhcp excluded-address 172.16.10.1 172.16.10.50
ip dhcp excluded-address 172.16.10.100 172.16.10.255
ip dhcp pool VLAN20
 network 172.16.20.0 255.255.255.0
 default-router 172.16.20.253
ip dhcp excluded-address 172.16.20.1 172.16.20.50
ip dhcp excluded-address 172.16.20.100 172.16.20.254
ip dhcp pool VLAN30
 network 172.16.30.0 255.255.255.0
 default-router 172.16.30.252
ip dhcp excluded-address 172.16.30.1 172.16.30.50
ip dhcp excluded-address 172.16.30.100 172.16.30.254
ip dhcp pool VLAN40
 network 172.16.40.0 255.255.255.0
 default-router 172.16.40.253
ip dhcp excluded-address 172.16.40.1 172.16.40.50
ip dhcp excluded-address 172.16.40.100 172.16.40.254

AS1

hostname AS1
!
interface range g0/0-3,g1/0-3,g2/0-3,g3/0-3
 shutdown
no ip routing
!
spanning-tree mode rapid-pvst
!
vlan 10
vlan 20
vlan 30
vlan 40
vlan 99
 name management
!
interface g2/0
 switchport mode access
 switchport access vlan 10
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/1
 switchport mode access
 switchport access vlan 20
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/2
 switchport mode access
 switchport access vlan 30
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/3
 switchport mode access
 switchport access vlan 40
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface range g0/0,g1/0
 channel-group 1 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 channel-group 2 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po1,po2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown

AS2

hostname AS2
!
interface range g0/0-3,g1/0-3,g2/0-3,g3/0-3
 shutdown
no ip routing
!
spanning-tree mode rapid-pvst
!
vlan 10
vlan 20
vlan 30
vlan 40
vlan 99
 name management
!
interface g2/0
 switchport mode access
 switchport access vlan 10
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/1
 switchport mode access
 switchport access vlan 20
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/2
 switchport mode access
 switchport access vlan 30
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface g2/3
 switchport mode access
 switchport access vlan 40
 spanning-tree portfast
 spanning-tree bpduguard enable
 no shutdown
interface range g0/0,g1/0
 channel-group 4 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range g0/1,g1/1
 channel-group 5 mode desirable
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown
interface range po4,po5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 99
 switchport mode trunk
 no shutdown

Laisser un commentaire