Objectifs de certification

ICND2 200-105

  • 1.5 Configurer, vérifier et dépanner EtherChannel Couche 2/Couche 3 Static, PAGP, LACP

CCNA R&S 200-125

  • 2.9 Configurer, vérifier et dépanner EtherChannel Couche 2/Couche 3 (Static, PAGP, LACP)

Cisco Etherchannel : configuration, vérification et dépannage

1. Technologie Etherchannel

EtherChannel est une technologie d’agrégation de liens qui permet d’assembler plusieurs liens physiques Ethernet identiques en un seul lien logique. On l’appelle aussi bonding, LAG, etherchannel, ou encore portchannel.

Le but est d’augmenter la vitesse et la tolérance aux pannes entre les commutateurs, les routeurs et les serveurs. Elle permet de simplifier une topologie Spanning-Tree en diminuant le nombre de liens.

Un lien EtherChannel groupe de 2 à 8 liens actifs de 100 Mbit/s, 1 Gbit/s et 10 Gbit/s, plus éventuellement de 1 à 8 liens inactifs en réserve qui deviennent actifs quand des liens actifs sont coupés.

EtherChannel est principalement utilisé sur la dorsale du réseau local, dans le “switch block” entre la couche Access et Distribution, mais on peut aussi l’utiliser pour connecter des postes d’utilisateurs, des serveurs.

La technologie EtherChannel a été inventée par la société Kalpana au début des années 1990. Cette société a ensuite été acquise par Cisco Systems en 1994. En 2000, l’IEEE a publié le standard 802.3ad, qui est une version ouverte de EtherChannel.

1.1. Disponibilité dans le LAN

CoucheProtocole/SolutionsDélais de reprise
L1EtherchannelPlus ou moins 1 seconde pour rediriger le trafic sur un lien alternatif
L2Rapid Spanning TreeQuelques secondes
L3First Hop Redundancy Protocols comme HSRP, VRRP, GLBP10 secondes par défaut (Cisco) mais le constructeur conseille 1s hello time, 3s Hold Time
L3Protocoles de routageEn dessous de la seconde avec OSPF ou EIGRP

1.2. Configuration Cisco

Sur une interface, on indique à quel Groupe Etherchannel elle appartient. On trouvera des configurations :

  • Statique
  • Dynamique, via un protocole qui négocie l’agrégation :
    • Port Aggregation Protocol (PAgP)
    • Link Aggregation Control Protocol (LACP).

1.3. EtherChannel et IEEE 802.3ad

Les protocoles EtherChannel et IEEE 802.3ad sont très semblables et accomplissent le même but.

Il y a néanmoins quelques différences entre les deux :

  • EtherChannel est un protocole propriétaire de Cisco, alors que 802.3ad est un standard ouvert
  • EtherChannel nécessite de configurer précisément le commutateur, alors que 802.3ad n’a besoin que d’une configuration initiale
  • EtherChannel prend en charge plusieurs modes de distribution de la charge sur les différents liens, alors que 802.3ad n’a qu’un mode standard
  • EtherChannel peut être configuré automatiquement à la fois par LACP et par PAgP, tandis que 802.3ad ne peut l’être que par LACP.

2. Configuration Etherchannel en Cisco IOS

2.1. Configuration L2

Switch(config)# interface range fa0/1 – 4 {we can use the range or single interface}
Switch(config-if-range)# channel-group [1 – 6] mode [auto | desirable | on | active | passive]
  • Le nombre de “channel-group” disponible dépend du type de commutateur.
  • Les modes “auto” (passif) et “desirable” (inconditionnellement) activent PAgP.
  • “Active” (inconditionnellement) et “passive” activent LACP.
  • Le mode “on” force l’interface à se lier sans PAgP ou LACP
(config-if-range)#channel-group 1 mode ?
  active     Enable LACP unconditionally
  auto       Enable PAgP only if a PAgP device is detected
  desirable  Enable PAgP unconditionally
  on         Enable Etherchannel only
  passive    Enable LACP only if a LACP device is detected

Cette commande créera une interface Port-Channel 1 avec une méthode de configuration obligatoire.

La configuration des paramètres Duplex, vitesse, Spanning-Tree, Access ou Trunk doivent être identiques sur les interfaces physiques du channel-group et l’interface Port-Channel.

Le tableau suivant donne les possibilités de configuration :

Interface XInterface YProtocole
DesirableDesirablePAgP
DesirableAutoPAgP
ActiveActiveLACP
ActivePassiveLACP

Auto en PAgP et Passive en LACP de part et d’autre des interfaces ne monte pas le Port-Channel créé.

2.2. Diagnostic L2

Switch# show interface etherchannel
Switch# show etherchannel [summary | port | load-balance | port-channel | detail]
Switch# show [pagp | lacp ] neighbors

2.3. Configuration L3

Désactivation switchport sur les interfaces physiques et configuration du mode Etherchannel “on” (Etherchannel sans LACP ou PAgP) :

SW0(config)#interface range g0/0-1
SW0(config-if-range)#no switchport
SW0(config-if-range)#no ip add
SW0(config-if-range)#channel-group 1 mode on

Désactivation switchport et adresse IP sur le port Etherchannel

SW0(config)#interface Po1
SW0(config-if)#no switchport
SW0(config-if)#ip add 192.168.2.1 255.255.255.0

Les interfaces doivent avoir des paramètres speed et mode identiques.

3. Exemple de configuration

L’image vios_l2-adventerprisek9-m.03.2017.qcow2 est la seule image IOSv qui permette de réaliser cet exercice en lab.

3.1. Topologie

Topologie de base Etherchannel
  • Vlan 10 (G3/0), VLAN 20 (G3/1) sur SW0 et sur SW1
  • SW0 STP root primary vlan 10, root secondary vlan 20
  • SW1 STP root primary vlan 20, root secondary vlan 10
  • Po1 sur SW0 et SW1 (G0/0 et G0/1) en mode Trunking
  • Po2 sur SW0 et SW1 (G0/2 et G0/3) en mode Trunking
  • PC1 connecté sur G3/0 de SW0 : 192.168.10.1/24
  • PC2 connecté sur G3/1 de SW0 : 192.168.20.1/24
  • PC3 connecté sur G3/0 de SW1 : 192.168.10.2/24
  • PC4 connecté sur G3/1 de SW1 : 192.168.20.2/24

3.2. Configuration des VLANs

Sur SW0 et sur SW1 :

(config)#vlan 10
(config-vlan)#exit
(config)#vlan 20
(config-vlan)#exit

3.3. Configuration de Spanning-Tree

Sur SW0 :

SW0(config)#spanning-tree vlan 10 root primary
SW0(config)#spanning-tree vlan 20 root secondary

Sur SW1 :

SW1(config)#spanning-tree vlan 20 root primary
SW1(config)#spanning-tree vlan 10 root secondary

3.4. Configuration des ports Access

Sur SW0 et sur SW1 :

(config)#int G3/0              
(config-if)#switchport mode access
(config-if)#switchport access vlan 10
(config-if)#exit
(config)#int G3/1                 
(config-if)#switchport mode access   
(config-if)#switchport access vlan 20
(config-if)#exit

3.5. Configuration Etherchannel

Sur SW0 et sur SW1 :

(config)#interface range G0/0-1
(config-if-range)#shutdown
(config-if-range)#switchport trunk encapsulation dot1q
(config-if-range)#switchport mode trunk
(config-if-range)#channel-group 1 mode desirable
(config-if-range)#no shutdown
(config-if-range)#exit
(config)#interface Po1
(config-if)#switchport trunk encapsulation dot1q
(config-if)#switchport mode trunk
(config-if)#exit
(config)#interface range G0/2-3
(config-if-range)#shutdown
(config-if-range)#switchport trunk encapsulation dot1q
(config-if-range)#switchport mode trunk
(config-if-range)#channel-group 2 mode active
(config-if-range)#no shutdown
(config-if-range)#exit
(config)#interface Po2
(config-if)#switchport trunk encapsulation dot1q
(config-if)#switchport mode trunk
(config-if)#exit

3.6. Diagnostic Spanning-Tree

Sur SW0 :

SW0#sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     007c.efbd.6900
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     007c.efbd.6900
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi3/0               Desg FWD 4         128.13   P2p
Po1                 Desg FWD 3         128.65   P2p
Po2                 Desg FWD 3         128.66   P2p


SW0#sh spanning-tree vlan 20

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    24596
             Address     007c.efaa.5600
             Cost        3
             Port        65 (Port-channel1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    28692  (priority 28672 sys-id-ext 20)
             Address     007c.efbd.6900
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi3/1               Desg LRN 4         128.14   P2p
Po1                 Root FWD 3         128.65   P2p
Po2                 Altn BLK 3         128.66   P2p



Sur SW1 :

SW1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     007c.efbd.6900
             Cost        3
             Port        65 (Port-channel1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    28682  (priority 28672 sys-id-ext 10)
             Address     007c.efaa.5600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi3/0               Desg FWD 4         128.13   P2p
Po1                 Root FWD 3         128.65   P2p
Po2                 Altn BLK 3         128.66   P2p


SW1#show spanning-tree vlan 20

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    24596
             Address     007c.efaa.5600
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24596  (priority 24576 sys-id-ext 20)
             Address     007c.efaa.5600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi3/1               Desg FWD 4         128.14   P2p
Po1                 Desg FWD 3         128.65   P2p
Po2                 Desg FWD 3         128.66   P2p



3.7. Diagnostic Etherchannel

SW0#sh etherchannel summary    
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

        A - formed by Auto LAG


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Gi0/0(P)    Gi0/1(P)    
2      Po2(SU)         LACP      Gi0/2(P)    Gi0/3(P)    


4. Fonctionnalités avancées

On citera ici quelques fonctionnalités avancées en dehors des sujets du CCNA.

On peut répartir la charge de liens Etherchannel sur plusieurs commutateurs (switches stackables ou des plateformes VSS pour “Virtual Switching System”)

La distribution du trafic sur plusieurs liens Etherchannel dépend d’un algorithme de Hash dont la méthode est configurable .

La fonctionnalité “Etherchannel Guard” permet d’éviter des erreurs de configuration (commande spanning-tree etherchannel guard misconfig)

5. Sources

5.1 Sources théoriques

5.2. Configuration SW0

hostname SW0
vlan10
vlan20
spanning-tree vlan 10 root primary
spanning-tree vlan 20 root secondary
int G3/0              
switchport mode access
switchport access vlan 10
int G3/1                 
switchport mode access   
switchport access vlan 20
interface range G0/0-1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
interface Po1
switchport trunk encapsulation dot1q
switchport mode trunk
interface range G0/2-3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
interface Po2
switchport trunk encapsulation dot1q
switchport mode trunk
end

5.3. Configuration SW1

hostname SW1
vlan10
vlan20
spanning-tree vlan 20 root primary
spanning-tree vlan 10 root secondary
int G3/0              
switchport mode access
switchport access vlan 10
int G3/1                 
switchport mode access   
switchport access vlan 20
interface range G0/0-1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
interface Po1
switchport trunk encapsulation dot1q
switchport mode trunk
interface range G0/2-3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
interface Po2
switchport trunk encapsulation dot1q
switchport mode trunk
end

Laisser un commentaire