Objectifs de certification

ICND1 100-105

  • 4.1 Décrire les opérations de recherche DNS
  • 4.2 Dépanner des problèmes de connectivité client impliquant DNS
  • 5.3 Configurer et vérifier la configuration initiale d'un périphérique
  • 4.3 Configurer et vérifier DHCP sur un routeur sauf les réservations statiques Server, Relay, Client, TFTP, DNS, and gateway options
  • 4.4 Dépanner des problèmes de connectivité DHCP client et routeur
  • 4.7. Configurer, vérifier et dépanner inside source NAT Static, Pool, PAT
  • 3.2 Interpréter les composants d'une table de routage Prefix, Network mask, Next hop, Routing protocol code, Administrative distance, Metric, Gateway of last resort
  • 3.5 Comparer et mettre en contraste le routage statique et le routage dynamique
  • 3.6 Configurer, vérifier et dépanner le routage statique IPv4 et IPv6 Default route, Network route, Host route, Floating static
  • 5.6 Utilisation des outils Cisco IOS pour dépanner et résoudre des problèmes Ping et traceroute avec l'option extended,Terminal monitor, Log events, Local SPAN

CCNA R&S 200-125

  • 5.1 Décrire les opérations de recherche DNS
  • 5.2 Dépanner des problèmes de connectivité client impliquant DNS
  • 7.4 Configurer et vérifier la configuration initiale d'un périphérique
  • 5.3 Configurer et vérifier DHCP sur un routeur sauf les réservations statiques (Server, Relay, Client, TFTP, DNS, and gateway options)
  • 5.4 Dépanner des problèmes de connectivité DHCP client et routeur
  • 6.2 Décrire les techniques d'atténuation des menaces sur la couche d'accès (802.1x, DHCP snooping, Nondefault native VLAN)
  • 5.6 Configurer, vérifier et dépanner inside source NAT (Static, Pool, PAT)
  • 3.2 Interpréter les composants d'une table de routage (Prefix, Network mask, Next hop, Routing protocol code, Administrative distance, Metric, Gateway of last resort)
  • 3.5 Comparer et mettre en contraste le routage statique et le routage dynamique
  • 3.8 Configurer, vérifier et dépanner le routage statique IPv4 et IPv6 (Default route, Network route, Host route, Floating static)
  • 7.6 Utilisation des outils Cisco IOS pour dépanner et résoudre des problèmes (Ping et traceroute avec l'option extended, Terminal monitor, Log events, Local SPAN)

Lab de routage et services IPv4/IPv6

Cet exercice pratique consiste à déployer la connectivité IPv4 et IPv6 de deux sites privés avec du NAT, du DNS et une solution DHCP “Relay” qui centralise le service d’attribution d’adresses IPv6.

1. Objectifs

  • Configurer le routage statique IPv4 ainsi que les services DHCP et DNS dans une topologie d’un inter-réseau privé qui se connecte à l’Internet.
  • Configurer le routage statique IPv6 ainsi que les services DHCP et DNS dans une topologie d’un inter-réseau privé.

2. Topologie de Lab IPv4

Topologie de Lab IPv4

R1 est le routeur central qui connecte l’Internet, Il fait office de routeur NAT overload (PAT), de serveur DHCP pour les deux LANs, et de serveur DNS pour la topologie. Le pare-feu n’est pas envisagé ici.

R2 est un routeur distant sur une connexion privée. Il fait office de serveur DHCP Relay.

Le routage statique IPv4 est configuré sur les deux routeurs.

On combine ici les deux exemples IPv4 de la présentation pour déployer le routage et les services internes.

2.1. Etapes de configuration

Sur R1 :

  • Configuration des interfaces
  • Configuration du routage statique
  • Configuration du NAT
  • Configuration du service DNS
  • Configuration du service NTP
  • Configuration du service DHCP

Sur R2 :

  • Configuration des interfaces
  • Configuration du routage statique
  • Configuration DHCP relay

2.2. R1 : Interfaces et routage

hostname R1
interface G0/0
 ip address 192.168.1.254 255.255.255.0
 no shutdown
interface G0/2
 ip address 192.168.0.253 255.255.255.252
 no shutdown
interface G0/1
 ip address dhcp
 no shutdown
ip route 192.168.0.0 255.255.255.128 192.168.0.254

2.3. R1 : NAT

ip nat inside source list nat interface G0/1 overload
ip access-list standard nat
 permit 192.168.1.0 0.0.0.255
 permit 192.168.0.0 0.0.0.255
interface G0/0
 ip nat inside
 interface G0/2
  ip nat inside
interface G0/1
 ip nat outside

2.4. R1 : DNS et NTP

ip domain-lookup
!
ip dns server
!
ip name-server 8.8.8.8
!
ntp server pool.ntp.org

2.5. R1 : DHCP

ip dhcp pool LAN
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.254
   dns-server 192.168.1.254
!
ip dhcp pool LAN2
   network 192.168.0.0 255.255.255.128
   default-router 192.168.0.126
   dns-server 192.168.1.254

2.6. R2 : Solution

hostname R2
interface G0/0
 ip address 192.168.0.126 255.255.255.128
 ip helper-address 192.168.0.253
 no shutdown
interface G0/1
 ip address 192.168.0.254 255.255.255.252
 no shutdown
ip route 0.0.0.0 0.0.0.0 192.168.0.253
end

2.7. DHCP Relay

Un choix de conception centralise le service DHCP sur R1. Par défaut le R2 bloque les requêtes DHCP adressée en Broadcast (255.255.255.255). Pour “relayer” en Unicast le message DHCP Discover auprès de R1, on réalise la tâche suivante :

R2(config)# interface G0/0
R2(config-if)# ip helper-address 192.168.0.253

On peut observer le processus de démarrage DHCP du PC2 à partir du routeur R2 sur ses interfaces G0/0 et G0/1. R2 traduit les adresses sources et destination du trafic DHCP Discover et relaie les messages suivants entre le client et le véritable serveur DHCP.

R2 traduit les adresses sources et destination du trafic DHCP Discover et relaie les messages suivants.

2.8. Diagnostic PC2

Sous VPCs

PC2> ip dhcp
DDORA IP 192.168.0.1/25 GW 192.168.0.126

PC2> ping www.google.com
www.google.com resolved to 194.78.99.180

84 bytes from 194.78.99.180 icmp_seq=1 ttl=126 time=40.344 ms
84 bytes from 194.78.99.180 icmp_seq=2 ttl=126 time=95.318 ms
84 bytes from 194.78.99.180 icmp_seq=3 ttl=126 time=21.551 ms
84 bytes from 194.78.99.180 icmp_seq=4 ttl=126 time=31.208 ms
84 bytes from 194.78.99.180 icmp_seq=5 ttl=126 time=23.841 ms

2.9. Diagnostic des routeurs

# show interface G0/0
# show ip interface brief
# show ip interface G0/0
# show ip route
# show ip nat translations
# show ip dhcp binding
# show ntp status

3. Topologie routage IPv6

Voici un lab de routage IPv6 minimal avec de l’adressage Global, ULA et Link-local. SLAAC est automatiquement activé !

Topologie routage IPv6

3.1. Étapes de configuration

  • Configuration des interfaces LAN et WAN
  • Activation du routage IPv6
  • Configuration du routage statique
  • Vérifications IPv6
  • Configuration DHCPv6 stateless

3.2. Solution R1

hostname R1
ipv6 unicast-routing
interface G0/0
    ipv6 address FE80::1 link-local
    ipv6 address 2001:DB8:1AB:1::1/64
    ipv6 address FD0B:E954:B412:1::1/64
    no shutdown
interface G0/2
    ipv6 address FE80::1 link-local
    no shutdown
ipv6 route 2001:DB8:1AB:2::/64 G0/2 FE80::2
ipv6 route FD0B:E954:B412:2::/64 G0/2 FE80::2
end

3.3. Solution R2

hostname R2
ipv6 unicast-routing
interface G0/0
    ipv6 address FE80::2 link-local
    ipv6 address 2001:DB8:1AB:2::1/64
    ipv6 address FD0B:E954:B412:2::1/64
    no shutdown
interface G0/1
    ipv6 address FE80::2 link-local
    no shutdown
ipv6 route ::/0 G0/1 FE80::1
end

3.4. Diagnostic IPv6 sur le routeur

# show ipv6 interface brief
# show ipv6 interface G0/0
# show ipv6 route
R2#show ipv6 interface brief
GigabitEthernet0/0     [up/up]
    FE80::2
    2001:DB8:1AB:2::1
    FD0B:E954:B412:2::1
GigabitEthernet0/1     [up/up]
    FE80::2
GigabitEthernet0/2     [administratively down/down]
    unassigned
GigabitEthernet0/3     [administratively down/down]
    unassigned

3.5. show ipv6 interface G0/0

R2#show ipv6 interface G0/0
GigabitEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::2
  No Virtual link-local address(es):
  Global unicast address(es):
    2001:DB8:1AB:2::1, subnet is 2001:DB8:1AB:2::/64
    FD0B:E954:B412:2::1, subnet is FD0B:E954:B412:2::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:1
    FF02::1:FF00:2
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

3.7. show ipv6 route

R1#show ipv6 route
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       lA - LISP away, a - Application
C   2001:DB8:1AB:1::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:DB8:1AB:1::1/128 [0/0]
     via GigabitEthernet0/0, receive
S   2001:DB8:1AB:2::/64 [1/0]
     via FE80::2, GigabitEthernet0/2
C   FD0B:E954:B412:1::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   FD0B:E954:B412:1::1/128 [0/0]
     via GigabitEthernet0/0, receive
S   FD0B:E954:B412:2::/64 [1/0]
     via FE80::2, GigabitEthernet0/2
L   FF00::/8 [0/0]
     via Null0, receive

3.8. Configuration Serveur DHCPv6 Stateless

ipv6 dhcp pool LAN
 dns-server 2001:DB8:1AB:AAA::1
interface G0/0
 ipv6 nd other-config-flag
 ipv6 dhcp server LAN

3.9. Vérification ND

show ipv6 interface G0/0
GigabitEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1
  No Virtual link-local address(es):
  Global unicast address(es):
    2001:DB8:1AB:1::1, subnet is 2001:DB8:1AB:1::/64
    FD0B:E954:B412:1::1, subnet is FD0B:E954:B412:1::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:2
    FF02::1:FF00:1
    FF05::1:3
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  Input features: Common Flow Table Stile classification
  Output features: Common Flow Table Stile Classification
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.
  Hosts use DHCP to obtain other configuration.

3.10. Vérification du client IPv6

Adresses IPv6

ip -6 a                                                      
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd0b:e954:b412:1:ec0:ecff:fe86:8d00/64 scope global noprefixroute dynamic
       valid_lft 2591991sec preferred_lft 604791sec
    inet6 2001:db8:1ab:1:ec0:ecff:fe86:8d00/64 scope global noprefixroute dynamic
       valid_lft 2591991sec preferred_lft 604791sec
    inet6 fe80::ec0:ecff:fe86:8d00/64 scope link
       valid_lft forever preferred_lft forever

Groupes Multicast

ip -6 maddress
1:	lo
	inet6 ff02::1
	inet6 ff01::1
2:	eth0
	inet6 ff02::1:ff86:8d00 users 3
	inet6 ff02::1
	inet6 ff01::1

Voisins IPv6

ip -6 neigh
fe80::1 dev eth0 lladdr 0c:c0:ec:ae:a5:00 router STALE

Table de routage IPv6

ip -6 route
unreachable ::/96 dev lo  metric 1024  error -113
unreachable ::ffff:0.0.0.0/96 dev lo  metric 1024  error -113
2001:db8:1ab:1::/64 dev eth0  proto ra  metric 100
unreachable 2002:a00::/24 dev lo  metric 1024  error -113
unreachable 2002:7f00::/24 dev lo  metric 1024  error -113
unreachable 2002:a9fe::/32 dev lo  metric 1024  error -113
unreachable 2002:ac10::/28 dev lo  metric 1024  error -113
unreachable 2002:c0a8::/32 dev lo  metric 1024  error -113
unreachable 2002:e000::/19 dev lo  metric 1024  error -113
unreachable 3ffe:ffff::/32 dev lo  metric 1024  error -113
fd0b:e954:b412:1::/64 dev eth0  proto ra  metric 100
fe80::1 dev eth0  proto static  metric 100
fe80::/64 dev eth0  proto kernel  metric 256
default via fe80::1 dev eth0  proto static  metric 100

Une capture du démarrage du PC montre un paquet de type RA ICMP 134 avec le drapeau “Other” qui est activé. Un message DHCPv6 Information-Request est envoyé par le client et le serveur répond avec un DHCPv6 Reply contenant les paramètres attendus.

Laisser un commentaire