Objectifs de certification

CCNA R&S 200-125

  • 3.11 Configurer, vérifier et dépanner EIGRP pour IPv4 sauf authentification, filtrage, summarization manuelle, redistribution, stub

  • 3.12 Configurer, vérifier et dépanner EIGRP pour IPv6 sauf authentification, filtrage, summarization manuelle, redistribution, stub


Lab Routage EIGRP

Introduction

EIGRP le protocole de routage à vecteur avancé propriétaire Cisco. Il est aisé à configurer, il est robuste et performant.

On trouvera ici un lab de configuration de EIGRP en IPv4 et en IPv6 dans une topologie maillée à trois routeurs.

Topologie EIGRP IPv4 IPv6

Topologie EIGRP IPv4 IPv6

Mise en place IPv6

Sur R1 :

hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 no shutdown
 ipv6 address FE80::1 link-local
 ipv6 address FD00:FD00:FD00:1::1/64
 ipv6 eigrp 1
!
interface GigabitEthernet0/2
 no shutdown
 ipv6 address FE80::1 link-local
 ipv6 eigrp 1
!
interface GigabitEthernet0/3
 no shutdown
 ipv6 address FE80::1 link-local
 ipv6 eigrp 1
!
ipv6 router eigrp 1
 passive-interface GigabitEthernet0/0
 eigrp router-id 1.1.1.1
!
end

Sur R2 :

hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
 no shutdown
 ipv6 address FE80::2 link-local
 ipv6 address FD00:FD00:FD00:2::1/64
 ipv6 eigrp 1
!
interface GigabitEthernet0/1
 no shutdown
 ipv6 address FE80::2 link-local
 ipv6 eigrp 1
!
interface GigabitEthernet0/3
 no shutdown
 ipv6 address FE80::2 link-local
 ipv6 eigrp 1
!
ipv6 router eigrp 1
 passive-interface GigabitEthernet0/0
 eigrp router-id 2.2.2.2
!
end

Sur R3 :

hostname R3
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0
 no shutdown
 ipv6 address FE80::3 link-local
 ipv6 address FD00:FD00:FD00:3::1/64
 ipv6 eigrp 1
!
interface GigabitEthernet0/1
 no shutdown
 ipv6 address FE80::3 link-local
 ipv6 eigrp 1
!
interface GigabitEthernet0/2
 no shutdown
 ipv6 address FE80::3 link-local
 ipv6 eigrp 1
!
ipv6 router eigrp 1
 passive-interface GigabitEthernet0/0
 eigrp router-id 3.3.3.3
!
end

Mise en place IPv4

Sur R1 :

hostname R1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 no shutdown
 ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/2
 no shutdown
 ip address 192.168.225.1 255.255.255.0
!
interface GigabitEthernet0/3
 no shutdown
 ip address 192.168.226.1 255.255.255.0
!
router eigrp 1
 passive-interface GigabitEthernet0/0
 eigrp router-id 1.1.1.1
 network 192.168.1.0
 network 192.168.225.0
 network 192.168.226.0
!
end

Sur R2 :

hostname R2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
 no shutdown
 ip address 192.168.33.1 255.255.255.0
!
interface GigabitEthernet0/1
 no shutdown
 ip address 192.168.225.2 255.255.255.0
!
interface GigabitEthernet0/3
 no shutdown
 ip address 192.168.227.1 255.255.255.0
!
router eigrp 1
 passive-interface GigabitEthernet0/0
 eigrp router-id 2.2.2.2
 network 192.168.33.0
 network 192.168.225.0
 network 192.168.227.0
!
end

Sur R3 :

hostname R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0
 no shutdown
 ip address 192.168.65.2 255.255.255.0
!
interface GigabitEthernet0/1
 no shutdown
 ip address 192.168.226.2 255.255.255.0
!
interface GigabitEthernet0/2
 no shutdown
 ip address 192.168.227.2 255.255.255.0
!
router eigrp 1
 passive-interface GigabitEthernet0/0
 eigrp router-id 3.3.3.3
 network 192.168.65.0
 network 192.168.226.0
 network 192.168.227.0
!
end

Vérification de la configuration EIGRP IPv4

# show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    Soft SIA disabled
    NSF-aware route hold timer is 240
    Router-ID: 1.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
    192.168.225.0
    192.168.226.0
  Passive Interface(s):
    GigabitEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.225.2         90      00:04:29
  Distance: internal 90 external 170

Routage vers l’Internet

interface g0/1
 ip address dhcp
 no shutdown
access-list 1 permit 192.168.0.0 0.0.255.255
ip nat inside source list 1 interface g0/1 overload
interface g0/0
 ip nat inside
interface g0/2
 ip nat inside
interface g0/3
 ip nat inside
interface g0/1
 ip nat outside
router eigrp 1
 redistribute static
end
wr

Topologie adaptée

Topologie EIGRP IPv4 IPv6 adaptée

Bande passante administrative sur G0/2 de R1

Bande passante administrative sur G0/1 de R2

Laisser un commentaire